summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/msmtp/msmtp_1.8.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/msmtp/msmtp_1.8.4.bb')
-rw-r--r--meta/recipes-extended/msmtp/msmtp_1.8.4.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-extended/msmtp/msmtp_1.8.4.bb b/meta/recipes-extended/msmtp/msmtp_1.8.4.bb
new file mode 100644
index 0000000000..888c1bbb5a
--- /dev/null
+++ b/meta/recipes-extended/msmtp/msmtp_1.8.4.bb
@@ -0,0 +1,29 @@
1SUMMARY = "msmtp is an SMTP client"
2DESCRIPTION = "A sendmail replacement for use in MTAs like mutt"
3HOMEPAGE = "https://marlam.de/msmtp/"
4SECTION = "console/network"
5
6LICENSE = "GPLv3"
7DEPENDS = "zlib gnutls"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
10
11UPSTREAM_CHECK_URI = "https://marlam.de/msmtp/download/"
12
13SRC_URI = "https://marlam.de/${BPN}/releases/${BP}.tar.xz"
14SRC_URI[md5sum] = "abfabb92f0461137f3c09cd16d98fc9b"
15SRC_URI[sha256sum] = "e5dd7fe95bc8e2f5eea3e4894ec9628252f30bd700a7fd1a568b10efa91129f7"
16
17inherit gettext autotools update-alternatives pkgconfig
18
19EXTRA_OECONF += "--without-libsecret --without-libgsasl --without-libidn"
20
21ALTERNATIVE_${PN} = "sendmail"
22ALTERNATIVE_TARGET[sendmail] = "${bindir}/msmtp"
23ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail"
24ALTERNATIVE_PRIORITY = "100"
25
26pkg_postinst_${PN}_linuxstdbase () {
27 # /usr/lib/sendmial is required by LSB core test
28 [ ! -L $D/usr/lib/sendmail ] && ln -sf ${sbindir}/sendmail $D/usr/lib/
29}