summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm/mdadm_4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/mdadm/mdadm_4.0.bb')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_4.0.bb17
1 files changed, 15 insertions, 2 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_4.0.bb b/meta/recipes-extended/mdadm/mdadm_4.0.bb
index 2c4d88a9e7..8155ae41b4 100644
--- a/meta/recipes-extended/mdadm/mdadm_4.0.bb
+++ b/meta/recipes-extended/mdadm/mdadm_4.0.bb
@@ -24,12 +24,14 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.xz \
24 file://0001-Use-CC-to-check-for-implicit-fallthrough-warning-sup.patch \ 24 file://0001-Use-CC-to-check-for-implicit-fallthrough-warning-sup.patch \
25 file://0001-use-memmove-instead-of-memcpy-on-overlapping-region.patch \ 25 file://0001-use-memmove-instead-of-memcpy-on-overlapping-region.patch \
26 file://0001-Disable-gcc8-warnings.patch \ 26 file://0001-Disable-gcc8-warnings.patch \
27 file://mdadm.init \
28 file://mdmonitor.service \
27 " 29 "
28SRC_URI[md5sum] = "2cb4feffea9167ba71b5f346a0c0a40d" 30SRC_URI[md5sum] = "2cb4feffea9167ba71b5f346a0c0a40d"
29SRC_URI[sha256sum] = "1d6ae7f24ced3a0fa7b5613b32f4a589bb4881e3946a5a2c3724056254ada3a9" 31SRC_URI[sha256sum] = "1d6ae7f24ced3a0fa7b5613b32f4a589bb4881e3946a5a2c3724056254ada3a9"
30 32
31CFLAGS += "-fno-strict-aliasing" 33CFLAGS += "-fno-strict-aliasing"
32inherit autotools-brokensep 34inherit autotools-brokensep systemd
33 35
34EXTRA_OEMAKE = 'CHECK_RUN_DIR=0 CXFLAGS="${CFLAGS}"' 36EXTRA_OEMAKE = 'CHECK_RUN_DIR=0 CXFLAGS="${CFLAGS}"'
35# PPC64 and MIPS64 uses long long for u64 in the kernel, but powerpc's asm/types.h 37# PPC64 and MIPS64 uses long long for u64 in the kernel, but powerpc's asm/types.h
@@ -51,7 +53,17 @@ do_install() {
51 autotools_do_install 53 autotools_do_install
52} 54}
53 55
54inherit ptest 56do_install_append() {
57 install -d ${D}/${sysconfdir}/
58 install -m 644 ${S}/mdadm.conf-example ${D}${sysconfdir}/mdadm.conf
59 install -d ${D}/${systemd_unitdir}/system
60 install -m 644 ${S}/systemd/mdmonitor.service ${D}/${systemd_unitdir}/system
61 install -d ${D}/${sysconfdir}/init.d
62 install -m 755 ${WORKDIR}/mdadm.init ${D}${sysconfdir}/init.d/mdmonitor
63}
64
65SYSTEMD_SERVICE_${PN} = "mdmonitor.service"
66SYSTEMD_AUTO_ENABLE = "disable"
55 67
56do_compile_ptest() { 68do_compile_ptest() {
57 oe_runmake test 69 oe_runmake test
@@ -67,6 +79,7 @@ do_install_ptest() {
67 install -D -m 755 $prg ${D}${PTEST_PATH}/ 79 install -D -m 755 $prg ${D}${PTEST_PATH}/
68 done 80 done
69} 81}
82
70RDEPENDS_${PN}-ptest += "bash" 83RDEPENDS_${PN}-ptest += "bash"
71RRECOMMENDS_${PN}-ptest += " \ 84RRECOMMENDS_${PN}-ptest += " \
72 coreutils \ 85 coreutils \