summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm/mdadm_3.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/mdadm/mdadm_3.3.2.bb')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.3.2.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_3.3.2.bb b/meta/recipes-extended/mdadm/mdadm_3.3.2.bb
new file mode 100644
index 0000000000..c9392b43f6
--- /dev/null
+++ b/meta/recipes-extended/mdadm/mdadm_3.3.2.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Tool for managing software RAID under Linux"
2HOMEPAGE = "http://www.kernel.org/pub/linux/utils/raid/mdadm/"
3
4# Some files are GPLv2+ while others are GPLv2.
5LICENSE = "GPLv2 & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
8 file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
9
10
11SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.xz \
12 file://mdadm-3.2.2_fix_for_x32.patch \
13 file://gcc-4.9.patch \
14 "
15
16SRC_URI[md5sum] = "44698d351501cac6a89072dc877eb220"
17SRC_URI[sha256sum] = "0f3a7e1a76b13892b79f9fceaf99ecb23513260389a768ac644ffa3ae06e5b8c"
18
19CFLAGS += "-fno-strict-aliasing"
20
21inherit autotools-brokensep
22
23# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
24do_configure_prepend () {
25 sed -i -e '/.*ansidecl.h.*/d' ${S}/sha1.h
26}
27
28EXTRA_OEMAKE = "CHECK_RUN_DIR=0"
29# PPC64 and MIPS64 uses long long for u64 in the kernel, but powerpc's asm/types.h
30# prevents 64-bit userland from seeing this definition, instead defaulting
31# to u64 == long in userspace. Define __SANE_USERSPACE_TYPES__ to get
32# int-ll64.h included
33EXTRA_OEMAKE_append_powerpc64 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
34EXTRA_OEMAKE_append_mips64 = ' CFLAGS=-D__SANE_USERSPACE_TYPES__'
35
36do_compile() {
37 oe_runmake
38}
39
40do_install() {
41 export STRIP=""
42 autotools_do_install
43}
44
45FILES_${PN} += "${base_libdir}/udev/rules.d/*.rules"