summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm/mdadm_3.2.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/mdadm/mdadm_3.2.6.bb')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.2.6.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_3.2.6.bb b/meta/recipes-extended/mdadm/mdadm_3.2.6.bb
new file mode 100644
index 0000000000..7b6a6c7fe7
--- /dev/null
+++ b/meta/recipes-extended/mdadm/mdadm_3.2.6.bb
@@ -0,0 +1,38 @@
1DESCRIPTION = " A tool for managing Soft RAID under Linux"
2HOMEPAGE = "http://www.kernel.org/pub/linux/utils/raid/mdadm/"
3BUGTRACKER = "n/a"
4
5# Some files are GPLv2+ while others are GPLv2.
6LICENSE = "GPLv2 & GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
9 file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
10
11PR = "r0"
12
13SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.bz2 \
14 file://mdadm-3.2.2_fix_for_x32.patch \
15 "
16
17SRC_URI[md5sum] = "3e255dc71e5144bbcb872788ca647267"
18SRC_URI[sha256sum] = "c44ed3b31238b41cffe67caffaf45067d01e095de94988889ea8a94e22dc6c38"
19
20CFLAGS += "-fno-strict-aliasing"
21
22inherit autotools
23
24# We don't DEPEND on binutils for ansidecl.h so ensure we don't use the header
25do_configure_prepend () {
26 sed -i -e '/.*ansidecl.h.*/d' ${S}/sha1.h
27}
28
29do_compile() {
30 oe_runmake
31}
32
33do_install() {
34 export STRIP=""
35 autotools_do_install
36}
37
38FILES_${PN} += "${base_libdir}/udev/rules.d/*.rules"