summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/mdadm/mdadm_3.2.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/mdadm/mdadm_3.2.5.bb')
-rw-r--r--meta/recipes-extended/mdadm/mdadm_3.2.5.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_3.2.5.bb b/meta/recipes-extended/mdadm/mdadm_3.2.5.bb
new file mode 100644
index 0000000000..2d7e1d036f
--- /dev/null
+++ b/meta/recipes-extended/mdadm/mdadm_3.2.5.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = " A tool for managing Soft RAID under Linux"
2HOMEPAGE = "http://www.kernel.org/pub/linux/utils/raid/mdadm/"
3BUGTRACKER = "n/a"
4
5# Some files are GPLv2+ while others are GPLv2.
6LICENSE = "GPLv2 & GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://mdmon.c;beginline=4;endline=18;md5=af7d8444d9c4d3e5c7caac0d9d34039d \
9 file://mdadm.h;beglinlne=4;endline=22;md5=462bc9936ac0d3da110191a3f9994161"
10
11PR = "r0"
12
13SRC_URI = "${KERNELORG_MIRROR}/linux/utils/raid/mdadm/${BPN}-${PV}.tar.bz2 \
14 file://mdadm-3.2.2_fix_for_x32.patch \
15 "
16
17SRC_URI[md5sum] = "83ba4a6249ae24677e915e44c9cfcc58"
18SRC_URI[sha256sum] = "5ae2bfd241c88601c1ef9072806248491e025fa09a388c40230d72d65eabbd3c"
19
20CFLAGS += "-fno-strict-aliasing"
21
22inherit autotools
23
24do_compile() {
25 oe_runmake
26}
27
28do_install() {
29 export STRIP=""
30 autotools_do_install
31}
32
33FILES_${PN} += "${base_libdir}/udev/rules.d/*.rules"