summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-pages/man-pages_6.06.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/man-pages/man-pages_6.06.bb')
-rw-r--r--meta/recipes-extended/man-pages/man-pages_6.06.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-pages/man-pages_6.06.bb b/meta/recipes-extended/man-pages/man-pages_6.06.bb
new file mode 100644
index 0000000000..fa2e6b266e
--- /dev/null
+++ b/meta/recipes-extended/man-pages/man-pages_6.06.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Linux man-pages"
2DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
3SECTION = "console/utils"
4HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
5LICENSE = "GPL-2.0-or-later & GPL-2.0-only & GPL-1.0-or-later & BSD-2-Clause & BSD-3-Clause & BSD-4-Clause & MIT"
6
7LIC_FILES_CHKSUM = "file://README;md5=72cff06b7954222c24d38bc2c41b234e \
8 file://LICENSES/BSD-2-Clause.txt;md5=9e16594a228301089d759b4f178db91f \
9 file://LICENSES/BSD-3-Clause.txt;md5=407426fcc1a243b7b2eff6e35c56aca9 \
10 file://LICENSES/BSD-4-Clause-UC.txt;md5=1da3cf8ad50cd8d5d1de3cfc53196d01 \
11 file://LICENSES/GPL-1.0-or-later.txt;md5=e5b7c80002ef72ab868b43ce47b65125 \
12 file://LICENSES/GPL-2.0-only.txt;md5=3d26203303a722dedc6bf909d95ba815 \
13 file://LICENSES/GPL-2.0-or-later.txt;md5=3d26203303a722dedc6bf909d95ba815 \
14 file://LICENSES/Linux-man-pages-1-para.txt;md5=97ab07585ce6700273bc66461bf46bf2 \
15 file://LICENSES/Linux-man-pages-copyleft-2-para.txt;md5=1cafc230857da5e43f3d509c425d3c64 \
16 file://LICENSES/Linux-man-pages-copyleft.txt;md5=173b960c686ff2d26f043ddaeb63f6ce \
17 file://LICENSES/Linux-man-pages-copyleft-var.txt;md5=d33708712c5918521f47f23b0c4e0d20 \
18 file://LICENSES/MIT.txt;md5=7dda4e90ded66ab88b86f76169f28663 \
19 "
20SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/${BP}.tar.gz \
21 file://0001-man.ml-do-not-use-dev-stdin.patch \
22 "
23
24SRC_URI[sha256sum] = "006906e7be81a71c2d347809597bcb91485fa7fa488acdaa79e681ddfa894568"
25
26inherit manpages
27
28MAN_PKG = "${PN}"
29
30PACKAGECONFIG ??= ""
31PACKAGECONFIG[manpages] = ""
32
33do_configure[noexec] = "1"
34do_compile[noexec] = "1"
35
36do_install() {
37 oe_runmake install prefix=${prefix} DESTDIR=${D}
38 rm -rf ${D}${mandir}/man3/crypt.3
39 rm -rf ${D}${mandir}/man3/crypt_r.3
40 rm -rf ${D}${mandir}/man3/getspnam.3
41 rm -rf ${D}${mandir}/man5/passwd.5
42}
43
44# Only deliveres man-pages so FILES:${PN} gets everything
45FILES:${PN}-doc = ""
46FILES:${PN} = "${mandir}/*"