summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-pages/man-pages_5.08.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/man-pages/man-pages_5.08.bb')
-rw-r--r--meta/recipes-extended/man-pages/man-pages_5.08.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-pages/man-pages_5.08.bb b/meta/recipes-extended/man-pages/man-pages_5.08.bb
new file mode 100644
index 0000000000..caf9320a67
--- /dev/null
+++ b/meta/recipes-extended/man-pages/man-pages_5.08.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Linux man-pages"
2DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
3SECTION = "console/utils"
4HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
5LICENSE = "GPLv2+"
6
7LIC_FILES_CHKSUM = "file://README;md5=207f70f56526417514ac46b6680e314f"
8SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/${BP}.tar.gz"
9
10SRC_URI[sha256sum] = "6e0b8ae23ee9467cee701f23dea908257a93e5fffa9e261b19a23efbd27e84a2"
11
12inherit manpages
13
14MAN_PKG = "${PN}"
15
16PACKAGECONFIG ??= ""
17PACKAGECONFIG[manpages] = ""
18
19do_configure[noexec] = "1"
20do_compile[noexec] = "1"
21
22do_install() {
23 oe_runmake install DESTDIR=${D}
24}
25
26# Only deliveres man-pages so FILES_${PN} gets everything
27FILES_${PN}-doc = ""
28FILES_${PN} = "${mandir}/*"
29
30inherit update-alternatives
31
32ALTERNATIVE_PRIORITY = "100"
33ALTERNATIVE_${PN} = "passwd.5 getspnam.3 crypt.3"
34ALTERNATIVE_LINK_NAME[passwd.5] = "${mandir}/man5/passwd.5"
35ALTERNATIVE_LINK_NAME[getspnam.3] = "${mandir}/man3/getspnam.3"
36ALTERNATIVE_LINK_NAME[crypt.3] = "${mandir}/man3/crypt.3"