summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-db/man-db_2.9.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/man-db/man-db_2.9.4.bb')
-rw-r--r--meta/recipes-extended/man-db/man-db_2.9.4.bb59
1 files changed, 0 insertions, 59 deletions
diff --git a/meta/recipes-extended/man-db/man-db_2.9.4.bb b/meta/recipes-extended/man-db/man-db_2.9.4.bb
deleted file mode 100644
index 432953a1bc..0000000000
--- a/meta/recipes-extended/man-db/man-db_2.9.4.bb
+++ /dev/null
@@ -1,59 +0,0 @@
1SUMMARY = "An implementation of the standard Unix documentation system accessed using the man command"
2HOMEPAGE = "http://man-db.nongnu.org/"
3LICENSE = "LGPLv2.1 & GPLv2"
4LIC_FILES_CHKSUM = "file://docs/COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
5 file://docs/COPYING;md5=eb723b61539feef013de476e68b5c50a"
6
7SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/man-db/man-db-${PV}.tar.xz \
8 file://99_mandb \
9 file://man_db.conf-avoid-multilib-install-file-conflict.patch"
10SRC_URI[sha256sum] = "b66c99edfad16ad928c889f87cf76380263c1609323c280b3a9e6963fdb16756"
11
12DEPENDS = "libpipeline gdbm groff-native base-passwd"
13RDEPENDS_${PN} += "base-passwd"
14PACKAGE_WRITE_DEPS += "base-passwd"
15
16# | /usr/src/debug/man-db/2.8.0-r0/man-db-2.8.0/src/whatis.c:939: undefined reference to `_nl_msg_cat_cntr'
17USE_NLS_libc-musl = "no"
18
19inherit gettext pkgconfig autotools systemd
20
21EXTRA_OECONF = "--with-pager=less --with-systemdsystemunitdir=${systemd_unitdir}/system"
22EXTRA_AUTORECONF += "-I ${S}/gl/m4"
23
24do_install() {
25 autotools_do_install
26
27 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
28 install -d ${D}/etc/default/volatiles
29 install -m 0644 ${WORKDIR}/99_mandb ${D}/etc/default/volatiles
30 fi
31}
32
33do_install_append_libc-musl() {
34 rm -f ${D}${libdir}/charset.alias
35}
36
37FILES_${PN} += "${prefix}/lib/tmpfiles.d"
38
39FILES_${PN}-dev += "${libdir}/man-db/libman.so ${libdir}/${BPN}/libmandb.so"
40
41RDEPENDS_${PN} += "groff"
42RRECOMMENDS_${PN} += "less"
43RPROVIDES_${PN} += " man"
44
45def compress_pkg(d):
46 if bb.utils.contains("INHERIT", "compress_doc", True, False, d):
47 compress = d.getVar("DOC_COMPRESS")
48 if compress == "gz":
49 return "gzip"
50 elif compress == "bz2":
51 return "bzip2"
52 elif compress == "xz":
53 return "xz"
54 return ""
55
56RDEPENDS_${PN} += "${@compress_pkg(d)}"
57
58SYSTEMD_SERVICE_${PN} = "man-db.timer man-db.service"
59SYSTEMD_AUTO_ENABLE ?= "disable"