summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-db/man-db_2.12.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/man-db/man-db_2.12.1.bb')
-rw-r--r--meta/recipes-extended/man-db/man-db_2.12.1.bb72
1 files changed, 72 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-db/man-db_2.12.1.bb b/meta/recipes-extended/man-db/man-db_2.12.1.bb
new file mode 100644
index 0000000000..5c6797c8f1
--- /dev/null
+++ b/meta/recipes-extended/man-db/man-db_2.12.1.bb
@@ -0,0 +1,72 @@
1SUMMARY = "An implementation of the standard Unix documentation system accessed using the man command"
2HOMEPAGE = "http://man-db.nongnu.org/"
3DESCRIPTION = "man-db is an implementation of the standard Unix documentation system accessed using the man command. It uses a Berkeley DB database in place of the traditional flat-text whatis databases."
4LICENSE = "LGPL-2.1-or-later & GPL-2.0-or-later & GPL-3.0-or-later"
5LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464 \
6 file://docs/COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://docs/COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8 "
9
10SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/man-db/man-db-${PV}.tar.xz \
11 file://99_mandb \
12 file://0001-man-Move-local-variable-declaration-to-function-scop.patch \
13 "
14SRC_URI[sha256sum] = "ddee249daeb78cf92bab794ccd069cc8b575992265ea20e239e887156e880265"
15
16DEPENDS = "libpipeline gdbm groff-native base-passwd"
17RDEPENDS:${PN} += "base-passwd"
18PACKAGE_WRITE_DEPS += "base-passwd"
19
20# | /usr/src/debug/man-db/2.8.0-r0/man-db-2.8.0/src/whatis.c:939: undefined reference to `_nl_msg_cat_cntr'
21USE_NLS:libc-musl = "no"
22
23inherit gettext pkgconfig autotools systemd
24
25EXTRA_OECONF = "--with-pager=less --with-systemdsystemunitdir=${systemd_system_unitdir}"
26EXTRA_AUTORECONF += "-I ${S}/gl/m4"
27
28PACKAGECONFIG[bzip2] = "--with-bzip2=bzip2,ac_cv_prog_have_bzip2='',bzip2"
29PACKAGECONFIG[gzip] = "--with-gzip=gzip,ac_cv_prog_have_gzip='',gzip"
30PACKAGECONFIG[lzip] = "--with-lzip=lzip,ac_cv_prog_have_lzip='',lzip"
31PACKAGECONFIG[lzma] = "--with-lzma=lzma,ac_cv_prog_have_lzma='',xz"
32PACKAGECONFIG[zstd] = "--with-zstd=zstd,ac_cv_prog_have_zstd='',zstd"
33PACKAGECONFIG[xz] = "--with-xz=xz,ac_cv_prog_have_xz='',xz"
34
35do_install() {
36 autotools_do_install
37
38 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
39 install -d ${D}/etc/default/volatiles
40 install -m 0644 ${UNPACKDIR}/99_mandb ${D}/etc/default/volatiles
41 fi
42}
43
44do_install:append:libc-musl() {
45 rm -f ${D}${libdir}/charset.alias
46}
47
48FILES:${PN} += "${prefix}/lib/tmpfiles.d"
49
50FILES:${PN}-dev += "${libdir}/man-db/libman.so ${libdir}/${BPN}/libmandb.so"
51
52RDEPENDS:${PN} += "groff"
53RRECOMMENDS:${PN} += "less"
54# iconv from glibc-utils can be used to transform encoding
55RRECOMMENDS:${PN}:append:libc-glibc = " glibc-utils"
56RPROVIDES:${PN} += "man"
57
58def compress_pkg(d):
59 if bb.utils.contains("INHERIT", "compress_doc", True, False, d):
60 compress = d.getVar("DOC_COMPRESS")
61 if compress == "gz":
62 return "gzip"
63 elif compress == "bz2":
64 return "bzip2"
65 elif compress == "xz":
66 return "xz"
67 return ""
68
69RDEPENDS:${PN} += "${@compress_pkg(d)}"
70
71SYSTEMD_SERVICE:${PN} = "man-db.timer man-db.service"
72SYSTEMD_AUTO_ENABLE ?= "disable"