summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lzip/lzip_1.24.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/lzip/lzip_1.24.1.bb')
-rw-r--r--meta/recipes-extended/lzip/lzip_1.24.1.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-extended/lzip/lzip_1.24.1.bb b/meta/recipes-extended/lzip/lzip_1.24.1.bb
new file mode 100644
index 0000000000..6eda012734
--- /dev/null
+++ b/meta/recipes-extended/lzip/lzip_1.24.1.bb
@@ -0,0 +1,42 @@
1SUMMARY = "Lossless data compressor based on the LZMA algorithm"
2HOMEPAGE = "http://lzip.nongnu.org/lzip.html"
3DESCRIPTION = "Lzip is a lossless data compressor with a user interface similar to the one of gzip or bzip2. Lzip uses a simplified form of the Lempel-Ziv-Markov chain-Algorithm (LZMA) stream format, chosen to maximize safety and interoperability."
4SECTION = "console/utils"
5LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=76d6e300ffd8fb9d18bd9b136a9bba13 \
7 file://decoder.cc;beginline=3;endline=16;md5=18c279060cd0be128188404b45837f88 \
8 "
9
10SRC_URI = "${SAVANNAH_GNU_MIRROR}/lzip/lzip-${PV}.tar.gz"
11SRC_URI[sha256sum] = "30c9cb6a0605f479c496c376eb629a48b0a1696d167e3c1e090c5defa481b162"
12
13B = "${WORKDIR}/build"
14do_configure[cleandirs] = "${B}"
15
16CONFIGUREOPTS = "\
17 '--srcdir=${S}' \
18 '--prefix=${prefix}' \
19 '--exec-prefix=${exec_prefix}' \
20 '--bindir=${bindir}' \
21 '--datadir=${datadir}' \
22 '--infodir=${infodir}' \
23 '--sysconfdir=${sysconfdir}' \
24 'CXX=${CXX}' \
25 'CPPFLAGS=${CPPFLAGS}' \
26 'CXXFLAGS=${CXXFLAGS}' \
27 'LDFLAGS=${LDFLAGS}' \
28"
29
30do_configure () {
31 ${S}/configure ${CONFIGUREOPTS}
32}
33
34do_install () {
35 oe_runmake 'DESTDIR=${D}' install
36 # Info dir listing isn't interesting at this point so remove it if it exists.
37 if [ -e "${D}${infodir}/dir" ]; then
38 rm -f ${D}${infodir}/dir
39 fi
40}
41
42BBCLASSEXTEND = "native nativesdk"