summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lzip/lzip_1.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/lzip/lzip_1.22.bb')
-rw-r--r--meta/recipes-extended/lzip/lzip_1.22.bb41
1 files changed, 0 insertions, 41 deletions
diff --git a/meta/recipes-extended/lzip/lzip_1.22.bb b/meta/recipes-extended/lzip/lzip_1.22.bb
deleted file mode 100644
index d21c36a3f4..0000000000
--- a/meta/recipes-extended/lzip/lzip_1.22.bb
+++ /dev/null
@@ -1,41 +0,0 @@
1SUMMARY = "Lossless data compressor based on the LZMA algorithm"
2HOMEPAGE = "http://lzip.nongnu.org/lzip.html"
3SECTION = "console/utils"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=76d6e300ffd8fb9d18bd9b136a9bba13 \
6 file://decoder.cc;beginline=3;endline=16;md5=18c279060cd0be128188404b45837f88 \
7 "
8
9SRC_URI = "${SAVANNAH_GNU_MIRROR}/lzip/lzip-${PV}.tar.gz"
10SRC_URI[sha256sum] = "c3342d42e67139c165b8b128d033b5c96893a13ac5f25933190315214e87a948"
11
12B = "${WORKDIR}/build"
13do_configure[cleandirs] = "${B}"
14
15CONFIGUREOPTS = "\
16 '--srcdir=${S}' \
17 '--prefix=${prefix}' \
18 '--exec-prefix=${exec_prefix}' \
19 '--bindir=${bindir}' \
20 '--datadir=${datadir}' \
21 '--infodir=${infodir}' \
22 '--sysconfdir=${sysconfdir}' \
23 'CXX=${CXX}' \
24 'CPPFLAGS=${CPPFLAGS}' \
25 'CXXFLAGS=${CXXFLAGS}' \
26 'LDFLAGS=${LDFLAGS}' \
27"
28
29do_configure () {
30 ${S}/configure ${CONFIGUREOPTS}
31}
32
33do_install () {
34 oe_runmake 'DESTDIR=${D}' install
35 # Info dir listing isn't interesting at this point so remove it if it exists.
36 if [ -e "${D}${infodir}/dir" ]; then
37 rm -f ${D}${infodir}/dir
38 fi
39}
40
41BBCLASSEXTEND = "native nativesdk"