diff options
Diffstat (limited to 'meta/recipes-extended/ltp/ltp_20200515.bb')
-rw-r--r-- | meta/recipes-extended/ltp/ltp_20200515.bb | 111 |
1 files changed, 111 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp_20200515.bb b/meta/recipes-extended/ltp/ltp_20200515.bb new file mode 100644 index 0000000000..37bad53766 --- /dev/null +++ b/meta/recipes-extended/ltp/ltp_20200515.bb | |||
@@ -0,0 +1,111 @@ | |||
1 | SUMMARY = "Linux Test Project" | ||
2 | DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features." | ||
3 | HOMEPAGE = "https://linux-test-project.github.io/" | ||
4 | SECTION = "console/utils" | ||
5 | LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause" | ||
6 | LIC_FILES_CHKSUM = "\ | ||
7 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
8 | file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ | ||
9 | file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \ | ||
10 | file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \ | ||
11 | file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \ | ||
12 | file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \ | ||
13 | file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \ | ||
14 | file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
15 | " | ||
16 | |||
17 | DEPENDS = "attr libaio libcap acl openssl zip-native" | ||
18 | DEPENDS_append_libc-musl = " fts " | ||
19 | EXTRA_OEMAKE_append_libc-musl = " LIBC=musl " | ||
20 | EXTRA_OECONF_append_libc-musl = " LIBS=-lfts " | ||
21 | |||
22 | # since ltp contains x86-64 assembler which uses the frame-pointer register, | ||
23 | # set -fomit-frame-pointer x86-64 to handle cases where optimisation | ||
24 | # is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer | ||
25 | # earlier in CFLAGS, etc. | ||
26 | CFLAGS_append_x86-64 = " -fomit-frame-pointer" | ||
27 | |||
28 | CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__" | ||
29 | CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__" | ||
30 | SRCREV = "0d79a93e6ca44d9bc95973faea6bcd7b0c6d1f43" | ||
31 | |||
32 | SRC_URI = "git://github.com/linux-test-project/ltp.git \ | ||
33 | file://0001-build-Add-option-to-select-libc-implementation.patch \ | ||
34 | file://0004-guard-mallocopt-with-__GLIBC__.patch \ | ||
35 | file://0007-Fix-test_proc_kill-hanging.patch \ | ||
36 | file://0001-Add-more-musl-exclusions.patch \ | ||
37 | " | ||
38 | |||
39 | S = "${WORKDIR}/git" | ||
40 | |||
41 | inherit autotools-brokensep pkgconfig | ||
42 | |||
43 | TARGET_CC_ARCH += "${LDFLAGS}" | ||
44 | |||
45 | export prefix = "/opt/${PN}" | ||
46 | export exec_prefix = "/opt/${PN}" | ||
47 | |||
48 | PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl," | ||
49 | EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4" | ||
50 | EXTRA_OECONF = " --with-power-management-testsuite --with-realtime-testsuite --with-open-posix-testsuite " | ||
51 | # ltp network/rpc test cases ftbfs when libtirpc is found | ||
52 | EXTRA_OECONF += " --without-tirpc " | ||
53 | |||
54 | do_install(){ | ||
55 | install -d ${D}${prefix}/ | ||
56 | oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install | ||
57 | |||
58 | # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run | ||
59 | # as it lacks dependency on some perl moudle such as LWP::Simple | ||
60 | # And this script previously works as a tool for analyzing failures from LTP | ||
61 | # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses | ||
62 | # http://khack.osdl.org to retrieve ltp test results run on | ||
63 | # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible | ||
64 | rm -rf ${D}${prefix}/bin/STPfailure_report.pl | ||
65 | |||
66 | # Copy POSIX test suite into ${D}${prefix}/testcases by manual | ||
67 | cp -r testcases/open_posix_testsuite ${D}${prefix}/testcases | ||
68 | |||
69 | # Makefile were configured in the build system | ||
70 | find ${D}${prefix} -name Makefile | xargs -n 1 sed -i \ | ||
71 | -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \ | ||
72 | -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \ | ||
73 | -e 's@[^ ]*--sysroot=[^ "]*@@g' | ||
74 | } | ||
75 | |||
76 | RDEPENDS_${PN} = "\ | ||
77 | attr \ | ||
78 | bash \ | ||
79 | cpio \ | ||
80 | cronie \ | ||
81 | curl \ | ||
82 | e2fsprogs-mke2fs \ | ||
83 | expect \ | ||
84 | file \ | ||
85 | gawk \ | ||
86 | gzip \ | ||
87 | iproute2 \ | ||
88 | ldd \ | ||
89 | libaio \ | ||
90 | logrotate \ | ||
91 | perl \ | ||
92 | python3-core \ | ||
93 | procps \ | ||
94 | quota \ | ||
95 | unzip \ | ||
96 | util-linux \ | ||
97 | which \ | ||
98 | tar \ | ||
99 | " | ||
100 | |||
101 | FILES_${PN} += "${prefix}/* ${prefix}/runtest/* ${prefix}/scenario_groups/* ${prefix}/testcases/bin/* ${prefix}/testcases/bin/*/bin/* ${prefix}/testscripts/* ${prefix}/testcases/open_posix_testsuite/* ${prefix}/testcases/open_posix_testsuite/conformance/* ${prefix}/testcases/open_posix_testsuite/Documentation/* ${prefix}/testcases/open_posix_testsuite/functional/* ${prefix}/testcases/open_posix_testsuite/include/* ${prefix}/testcases/open_posix_testsuite/scripts/* ${prefix}/testcases/open_posix_testsuite/stress/* ${prefix}/testcases/open_posix_testsuite/tools/* ${prefix}/testcases/data/nm01/lib.a ${prefix}/lib/libmem.a" | ||
102 | |||
103 | # Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail | ||
104 | INHIBIT_PACKAGE_STRIP_FILES = "${prefix}/testcases/bin/nm01 ${prefix}/testcases/bin/ldd01" | ||
105 | INSANE_SKIP_${PN} += "already-stripped staticdev" | ||
106 | |||
107 | # Avoid file dependency scans, as LTP checks for things that may or may not | ||
108 | # exist on the running system. For instance it has specific checks for | ||
109 | # csh and ksh which are not typically part of OpenEmbedded systems (but | ||
110 | # can be added via additional layers.) | ||
111 | SKIP_FILEDEPS_${PN} = '1' | ||