summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp/ltp_20180926.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/ltp/ltp_20180926.bb')
-rw-r--r--meta/recipes-extended/ltp/ltp_20180926.bb123
1 files changed, 123 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp_20180926.bb b/meta/recipes-extended/ltp/ltp_20180926.bb
new file mode 100644
index 0000000000..622c1f42f7
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp_20180926.bb
@@ -0,0 +1,123 @@
1SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "http://ltp.sourceforge.net"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
11 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
13 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
14 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
15 file://utils/ffsb-6.0-rc2/COPYING;md5=c46082167a314d785d012a244748d803 \
16"
17
18DEPENDS = "attr libaio libcap acl openssl zip-native"
19DEPENDS_append_libc-musl = " fts "
20EXTRA_OEMAKE_append_libc-musl = " LIBC=musl "
21
22# since ltp contains x86-64 assembler which uses the frame-pointer register,
23# set -fomit-frame-pointer x86-64 to handle cases where optimisation
24# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
25# earlier in CFLAGS, etc.
26CFLAGS_append_x86-64 = " -fomit-frame-pointer"
27
28CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__"
29CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
30SRCREV = "f424769b1ad9fca477118763f88a6cec98ea2c0a"
31
32SRC_URI = "git://github.com/linux-test-project/ltp.git \
33 file://0004-build-Add-option-to-select-libc-implementation.patch \
34 file://0005-kernel-controllers-Link-with-libfts-explicitly-on-mu.patch \
35 file://0007-fix-__WORDSIZE-undeclared-when-building-with-musl.patch \
36 file://0008-Check-if-__GLIBC_PREREQ-is-defined-before-using-it.patch \
37 file://0009-fix-redefinition-of-struct-msgbuf-error-building-wit.patch \
38 file://0018-guard-mallocopt-with-__GLIBC__.patch \
39 file://0020-getdents-define-getdents-getdents64-only-for-glibc.patch \
40 file://0021-Define-_GNU_SOURCE-for-MREMAP_MAYMOVE-definition.patch \
41 file://0023-ptrace-Use-int-instead-of-enum-__ptrace_request.patch \
42 file://0024-rt_sigaction-rt_sigprocmark-Define-_GNU_SOURCE.patch \
43 file://0026-crash01-Define-_GNU_SOURCE.patch \
44 file://0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch \
45 file://0034-periodic_output.patch \
46 file://0035-fix-test_proc_kill-hang.patch \
47 file://0036-testcases-network-nfsv4-acl-acl1.c-Security-fix-on-s.patch \
48 file://0039-commands-ar01-Fix-for-test-in-deterministic-mode.patch \
49 file://0040-read_all-Define-FNM_EXTMATCH-if-not-already-like-und.patch \
50 file://0001-syscalls-fcntl-make-OFD-command-use-fcntl64-syscall-.patch \
51 file://0001-sigwaitinfo01-recent-glibc-calls-syscall-directly.patch \
52 file://0001-netns_helper.sh-use-ping-6-when-ping6-is-not-avaliab.patch \
53 file://0001-open_posix_testsuite-mmap24-2-Relax-condition-a-bit.patch \
54 file://0001-statx-fix-compile-errors.patch \
55 "
56
57S = "${WORKDIR}/git"
58
59inherit autotools-brokensep
60
61TARGET_CC_ARCH += "${LDFLAGS}"
62
63export prefix = "/opt/ltp"
64export exec_prefix = "/opt/ltp"
65
66PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
67EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
68EXTRA_OECONF = " --with-power-management-testsuite --with-realtime-testsuite --with-open-posix-testsuite "
69# ltp network/rpc test cases ftbfs when libtirpc is found
70EXTRA_OECONF += " --without-tirpc "
71
72do_install(){
73 install -d ${D}/opt/ltp/
74 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install
75
76 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
77 # as it lacks dependency on some perl moudle such as LWP::Simple
78 # And this script previously works as a tool for analyzing failures from LTP
79 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
80 # http://khack.osdl.org to retrieve ltp test results run on
81 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
82 rm -rf ${D}/opt/ltp/bin/STPfailure_report.pl
83
84 # Copy POSIX test suite into ${D}/opt/ltp/testcases by manual
85 cp -r testcases/open_posix_testsuite ${D}/opt/ltp/testcases
86}
87
88RDEPENDS_${PN} = "\
89 acl \
90 at \
91 attr \
92 bash \
93 cpio \
94 cronie \
95 curl \
96 e2fsprogs-mke2fs \
97 expect \
98 gawk \
99 gzip \
100 iproute2 \
101 ldd \
102 libaio \
103 logrotate \
104 perl \
105 python-core \
106 procps \
107 unzip \
108 util-linux \
109 which \
110 tar \
111"
112
113FILES_${PN} += "/opt/ltp/* /opt/ltp/runtest/* /opt/ltp/scenario_groups/* /opt/ltp/testcases/bin/* /opt/ltp/testcases/bin/*/bin/* /opt/ltp/testscripts/* /opt/ltp/testcases/open_posix_testsuite/* /opt/ltp/testcases/open_posix_testsuite/conformance/* /opt/ltp/testcases/open_posix_testsuite/Documentation/* /opt/ltp/testcases/open_posix_testsuite/functional/* /opt/ltp/testcases/open_posix_testsuite/include/* /opt/ltp/testcases/open_posix_testsuite/scripts/* /opt/ltp/testcases/open_posix_testsuite/stress/* /opt/ltp/testcases/open_posix_testsuite/tools/* /opt/ltp/testcases/data/nm01/lib.a /opt/ltp/lib/libmem.a"
114
115# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
116INHIBIT_PACKAGE_STRIP_FILES = "/opt/ltp/testcases/bin/nm01 /opt/ltp/testcases/bin/ldd01"
117INSANE_SKIP_${PN} += "already-stripped staticdev"
118
119# Avoid file dependency scans, as LTP checks for things that may or may not
120# exist on the running system. For instance it has specific checks for
121# csh and ksh which are not typically part of OpenEmbedded systems (but
122# can be added via additional layers.)
123SKIP_FILEDEPS_${PN} = '1'