summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp/ltp_20180515.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/ltp/ltp_20180515.bb')
-rw-r--r--meta/recipes-extended/ltp/ltp_20180515.bb112
1 files changed, 112 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp_20180515.bb b/meta/recipes-extended/ltp/ltp_20180515.bb
new file mode 100644
index 0000000000..b07c1b9268
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp_20180515.bb
@@ -0,0 +1,112 @@
1SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "http://ltp.sourceforge.net"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
11 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
13 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
14 file://tools/pounder21/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
15 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
16 file://utils/ffsb-6.0-rc2/COPYING;md5=c46082167a314d785d012a244748d803 \
17"
18
19DEPENDS = "attr libaio libcap acl openssl zip-native"
20DEPENDS_append_libc-musl = " fts "
21EXTRA_OEMAKE_append_libc-musl = " LIBC=musl "
22CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__"
23CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
24SRCREV = "96cbf48313afa65ef4d693d3441cbfd60a8d9b27"
25
26SRC_URI = "git://github.com/linux-test-project/ltp.git \
27 file://0004-build-Add-option-to-select-libc-implementation.patch \
28 file://0005-kernel-controllers-Link-with-libfts-explicitly-on-mu.patch \
29 file://0007-fix-__WORDSIZE-undeclared-when-building-with-musl.patch \
30 file://0008-Check-if-__GLIBC_PREREQ-is-defined-before-using-it.patch \
31 file://0009-fix-redefinition-of-struct-msgbuf-error-building-wit.patch \
32 file://0018-guard-mallocopt-with-__GLIBC__.patch \
33 file://0020-getdents-define-getdents-getdents64-only-for-glibc.patch \
34 file://0021-Define-_GNU_SOURCE-for-MREMAP_MAYMOVE-definition.patch \
35 file://0023-ptrace-Use-int-instead-of-enum-__ptrace_request.patch \
36 file://0024-rt_sigaction-rt_sigprocmark-Define-_GNU_SOURCE.patch \
37 file://0026-crash01-Define-_GNU_SOURCE.patch \
38 file://0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch \
39 file://0034-periodic_output.patch \
40 file://0035-fix-test_proc_kill-hang.patch \
41 file://0036-testcases-network-nfsv4-acl-acl1.c-Security-fix-on-s.patch \
42 file://0039-commands-ar01-Fix-for-test-in-deterministic-mode.patch \
43 file://0040-read_all-Define-FNM_EXTMATCH-if-not-already-like-und.patch \
44 "
45
46S = "${WORKDIR}/git"
47
48inherit autotools-brokensep
49
50TARGET_CC_ARCH += "${LDFLAGS}"
51
52export prefix = "/opt/ltp"
53export exec_prefix = "/opt/ltp"
54
55PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
56EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
57EXTRA_OECONF = " --with-power-management-testsuite --with-realtime-testsuite --with-open-posix-testsuite "
58# ltp network/rpc test cases ftbfs when libtirpc is found
59EXTRA_OECONF += " --without-tirpc "
60
61do_install(){
62 install -d ${D}/opt/ltp/
63 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install
64
65 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
66 # as it lacks dependency on some perl moudle such as LWP::Simple
67 # And this script previously works as a tool for analyzing failures from LTP
68 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
69 # http://khack.osdl.org to retrieve ltp test results run on
70 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
71 rm -rf ${D}/opt/ltp/bin/STPfailure_report.pl
72
73 # Copy POSIX test suite into ${D}/opt/ltp/testcases by manual
74 cp -r testcases/open_posix_testsuite ${D}/opt/ltp/testcases
75}
76
77RDEPENDS_${PN} = "\
78 acl \
79 at \
80 attr \
81 bash \
82 cpio \
83 cronie \
84 curl \
85 e2fsprogs-mke2fs \
86 expect \
87 gawk \
88 gzip \
89 iproute2 \
90 ldd \
91 libaio \
92 logrotate \
93 perl \
94 python-core \
95 procps \
96 unzip \
97 util-linux \
98 which \
99 tar \
100"
101
102FILES_${PN} += "/opt/ltp/* /opt/ltp/runtest/* /opt/ltp/scenario_groups/* /opt/ltp/testcases/bin/* /opt/ltp/testcases/bin/*/bin/* /opt/ltp/testscripts/* /opt/ltp/testcases/open_posix_testsuite/* /opt/ltp/testcases/open_posix_testsuite/conformance/* /opt/ltp/testcases/open_posix_testsuite/Documentation/* /opt/ltp/testcases/open_posix_testsuite/functional/* /opt/ltp/testcases/open_posix_testsuite/include/* /opt/ltp/testcases/open_posix_testsuite/scripts/* /opt/ltp/testcases/open_posix_testsuite/stress/* /opt/ltp/testcases/open_posix_testsuite/tools/* /opt/ltp/testcases/data/nm01/lib.a /opt/ltp/lib/libmem.a"
103
104# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
105INHIBIT_PACKAGE_STRIP_FILES = "/opt/ltp/testcases/bin/nm01 /opt/ltp/testcases/bin/ldd01"
106INSANE_SKIP_${PN} += "already-stripped staticdev"
107
108# Avoid file dependency scans, as LTP checks for things that may or may not
109# exist on the running system. For instance it has specific checks for
110# csh and ksh which are not typically part of OpenEmbedded systems (but
111# can be added via additional layers.)
112SKIP_FILEDEPS_${PN} = '1'