summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libsolv/libsolv_0.6.26.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libsolv/libsolv_0.6.26.bb')
-rw-r--r--meta/recipes-extended/libsolv/libsolv_0.6.26.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-extended/libsolv/libsolv_0.6.26.bb b/meta/recipes-extended/libsolv/libsolv_0.6.26.bb
new file mode 100644
index 0000000000..d46fca8e24
--- /dev/null
+++ b/meta/recipes-extended/libsolv/libsolv_0.6.26.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Library for solving packages and reading repositories"
2HOMEPAGE = "https://github.com/openSUSE/libsolv"
3BUGTRACKER = "https://github.com/openSUSE/libsolv/issues"
4SECTION = "devel"
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
7
8DEPENDS = "expat zlib"
9
10SRC_URI = "git://github.com/openSUSE/libsolv.git \
11 "
12SRC_URI_append_libc-musl = " file://0001-Add-fallback-fopencookie-implementation.patch"
13
14SRCREV = "ba32f8286d3deec6faaabc79762a4760e9af0a07"
15UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
16
17S = "${WORKDIR}/git"
18
19inherit cmake
20
21EXTRA_OECMAKE = "-DLIB=${baselib} -DMULTI_SEMANTICS=ON"
22
23PACKAGES =+ "${PN}-tools ${PN}ext"
24
25FILES_${PN}-dev += "${datadir}/cmake/Modules/FindLibSolv.cmake"
26FILES_${PN}-tools = "${bindir}/*"
27FILES_${PN}ext = "${libdir}/${PN}ext.so.*"
28
29BBCLASSEXTEND = "native nativesdk"