summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libidn/libidn2_2.3.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libidn/libidn2_2.3.7.bb')
-rw-r--r--meta/recipes-extended/libidn/libidn2_2.3.7.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-extended/libidn/libidn2_2.3.7.bb b/meta/recipes-extended/libidn/libidn2_2.3.7.bb
new file mode 100644
index 0000000000..7ae933e047
--- /dev/null
+++ b/meta/recipes-extended/libidn/libidn2_2.3.7.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Internationalized Domain Name support library"
2DESCRIPTION = "Implementation of the Stringprep, Punycode and IDNA specifications defined by the IETF Internationalized Domain Names (IDN) working group."
3HOMEPAGE = "http://www.gnu.org/software/libidn/"
4SECTION = "libs"
5LICENSE = "(GPL-2.0-or-later | LGPL-3.0-only) & GPL-3.0-or-later & Unicode-DFS-2016"
6LIC_FILES_CHKSUM = "file://COPYING;md5=2d834ea7d480438ada04e5d846152395 \
7 file://COPYING.LESSERv3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
8 file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
9 file://COPYING.unicode;md5=684cf5f7e3fded3546679424528261a9 \
10 file://src/idn2.c;endline=16;md5=afc1531bda991ba6338e33a7eff758a0 \
11 file://lib/idn2.h.in;endline=27;md5=f88d218005a5c45b68a83cecb5bd7f26 \
12 "
13
14SRC_URI = "${GNU_MIRROR}/libidn/${BPN}-${PV}.tar.gz"
15SRC_URI[sha256sum] = "4c21a791b610b9519b9d0e12b8097bf2f359b12f8dd92647611a929e6bfd7d64"
16
17DEPENDS = "virtual/libiconv libunistring"
18
19inherit pkgconfig autotools gettext texinfo gtk-doc lib_package
20
21EXTRA_OECONF += "--disable-rpath \
22 --with-libunistring-prefix=${STAGING_EXECPREFIXDIR} \
23 "
24
25do_install:append() {
26 # Need to remove any duplicate whitespace too for reproducibility
27 sed -i -e 's|-L${STAGING_LIBDIR}||' -e 's/ */ /g' ${D}${libdir}/pkgconfig/libidn2.pc
28}
29
30LICENSE:${PN} = "(GPL-2.0-or-later | LGPL-3.0-only) & Unicode-DFS-2016"
31LICENSE:${PN}-bin = "GPL-3.0-or-later"
32
33BBCLASSEXTEND = "native nativesdk"