summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libarchive/libarchive_3.7.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libarchive/libarchive_3.7.3.bb')
-rw-r--r--meta/recipes-extended/libarchive/libarchive_3.7.3.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-extended/libarchive/libarchive_3.7.3.bb b/meta/recipes-extended/libarchive/libarchive_3.7.3.bb
new file mode 100644
index 0000000000..bea91b6e97
--- /dev/null
+++ b/meta/recipes-extended/libarchive/libarchive_3.7.3.bb
@@ -0,0 +1,67 @@
1SUMMARY = "Support for reading various archive formats"
2DESCRIPTION = "C library and command-line tools for reading and writing tar, cpio, zip, ISO, and other archive formats"
3HOMEPAGE = "http://www.libarchive.org/"
4SECTION = "devel"
5LICENSE = "BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d499814247adaee08d88080841cb5665"
7
8DEPENDS = "e2fsprogs-native"
9
10PACKAGECONFIG ?= "zlib bz2 xz zstd ${@bb.utils.filter('DISTRO_FEATURES', 'acl xattr', d)}"
11
12DEPENDS_BZIP2 = "bzip2-replacement-native"
13DEPENDS_BZIP2:class-target = "bzip2"
14
15PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
16PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
17PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib,"
18PACKAGECONFIG[bz2] = "--with-bz2lib,--without-bz2lib,${DEPENDS_BZIP2},"
19PACKAGECONFIG[xz] = "--with-lzma,--without-lzma,xz,"
20PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl,"
21PACKAGECONFIG[libb2] = "--with-libb2,--without-libb2,libb2,"
22PACKAGECONFIG[libxml2] = "--with-xml2,--without-xml2,libxml2,"
23PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat,"
24PACKAGECONFIG[lzo] = "--with-lzo2,--without-lzo2,lzo,"
25PACKAGECONFIG[nettle] = "--with-nettle,--without-nettle,nettle,"
26PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4,"
27PACKAGECONFIG[mbedtls] = "--with-mbedtls,--without-mbedtls,mbedtls,"
28PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd,"
29
30EXTRA_OECONF += "--enable-largefile --without-iconv"
31
32SRC_URI = "http://libarchive.org/downloads/libarchive-${PV}.tar.gz"
33SRC_URI += "file://configurehack.patch"
34UPSTREAM_CHECK_URI = "http://libarchive.org/"
35
36SRC_URI[sha256sum] = "f27a97bc22ceb996e72502df47dc19f99f9a0f09181ae909f09f3c9eb17b67e2"
37
38CVE_STATUS[CVE-2023-30571] = "upstream-wontfix: upstream has documented that reported function is not thread-safe"
39
40inherit autotools update-alternatives pkgconfig
41
42CPPFLAGS += "-I${WORKDIR}/extra-includes"
43
44do_configure[cleandirs] += "${WORKDIR}/extra-includes"
45do_configure:prepend() {
46 # We just need the headers for some type constants, so no need to
47 # build all of e2fsprogs for the target
48 cp -R ${STAGING_INCDIR_NATIVE}/ext2fs ${WORKDIR}/extra-includes/
49}
50
51ALTERNATIVE_PRIORITY = "80"
52
53PACKAGES =+ "bsdtar"
54FILES:bsdtar = "${bindir}/bsdtar"
55
56ALTERNATIVE:bsdtar = "tar"
57ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
58ALTERNATIVE_TARGET[tar] = "${bindir}/bsdtar"
59
60PACKAGES =+ "bsdcpio"
61FILES:bsdcpio = "${bindir}/bsdcpio"
62
63ALTERNATIVE:bsdcpio = "cpio"
64ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
65ALTERNATIVE_TARGET[cpio] = "${bindir}/bsdcpio"
66
67BBCLASSEXTEND = "native nativesdk"