summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libarchive/libarchive_3.7.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libarchive/libarchive_3.7.2.bb')
-rw-r--r--meta/recipes-extended/libarchive/libarchive_3.7.2.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/meta/recipes-extended/libarchive/libarchive_3.7.2.bb b/meta/recipes-extended/libarchive/libarchive_3.7.2.bb
new file mode 100644
index 0000000000..a09f607fcf
--- /dev/null
+++ b/meta/recipes-extended/libarchive/libarchive_3.7.2.bb
@@ -0,0 +1,66 @@
1SUMMARY = "Support for reading various archive formats"
2DESCRIPTION = "C library and command-line tools for reading and writing tar, cpio, zip, ISO, and other archive formats"
3HOMEPAGE = "http://www.libarchive.org/"
4SECTION = "devel"
5LICENSE = "BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d499814247adaee08d88080841cb5665"
7
8DEPENDS = "e2fsprogs-native"
9
10PACKAGECONFIG ?= "zlib bz2 xz zstd ${@bb.utils.filter('DISTRO_FEATURES', 'acl xattr', d)}"
11
12DEPENDS_BZIP2 = "bzip2-replacement-native"
13DEPENDS_BZIP2:class-target = "bzip2"
14
15PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
16PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
17PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib,"
18PACKAGECONFIG[bz2] = "--with-bz2lib,--without-bz2lib,${DEPENDS_BZIP2},"
19PACKAGECONFIG[xz] = "--with-lzma,--without-lzma,xz,"
20PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl,"
21PACKAGECONFIG[libxml2] = "--with-xml2,--without-xml2,libxml2,"
22PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat,"
23PACKAGECONFIG[lzo] = "--with-lzo2,--without-lzo2,lzo,"
24PACKAGECONFIG[nettle] = "--with-nettle,--without-nettle,nettle,"
25PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4,"
26PACKAGECONFIG[mbedtls] = "--with-mbedtls,--without-mbedtls,mbedtls,"
27PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd,"
28
29EXTRA_OECONF += "--enable-largefile --without-iconv"
30
31SRC_URI = "http://libarchive.org/downloads/libarchive-${PV}.tar.gz"
32SRC_URI += "file://configurehack.patch"
33UPSTREAM_CHECK_URI = "http://libarchive.org/"
34
35SRC_URI[sha256sum] = "df404eb7222cf30b4f8f93828677890a2986b66ff8bf39dac32a804e96ddf104"
36
37CVE_STATUS[CVE-2023-30571] = "upstream-wontfix: upstream has documented that reported function is not thread-safe"
38
39inherit autotools update-alternatives pkgconfig
40
41CPPFLAGS += "-I${WORKDIR}/extra-includes"
42
43do_configure[cleandirs] += "${WORKDIR}/extra-includes"
44do_configure:prepend() {
45 # We just need the headers for some type constants, so no need to
46 # build all of e2fsprogs for the target
47 cp -R ${STAGING_INCDIR_NATIVE}/ext2fs ${WORKDIR}/extra-includes/
48}
49
50ALTERNATIVE_PRIORITY = "80"
51
52PACKAGES =+ "bsdtar"
53FILES:bsdtar = "${bindir}/bsdtar"
54
55ALTERNATIVE:bsdtar = "tar"
56ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
57ALTERNATIVE_TARGET[tar] = "${bindir}/bsdtar"
58
59PACKAGES =+ "bsdcpio"
60FILES:bsdcpio = "${bindir}/bsdcpio"
61
62ALTERNATIVE:bsdcpio = "cpio"
63ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
64ALTERNATIVE_TARGET[cpio] = "${bindir}/bsdcpio"
65
66BBCLASSEXTEND = "native nativesdk"