summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libarchive/libarchive_3.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libarchive/libarchive_3.2.2.bb')
-rw-r--r--meta/recipes-extended/libarchive/libarchive_3.2.2.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-extended/libarchive/libarchive_3.2.2.bb b/meta/recipes-extended/libarchive/libarchive_3.2.2.bb
new file mode 100644
index 0000000000..cf66e9d8e8
--- /dev/null
+++ b/meta/recipes-extended/libarchive/libarchive_3.2.2.bb
@@ -0,0 +1,67 @@
1SUMMARY = "Support for reading various archive formats"
2DESCRIPTION = "C library and command-line tools for reading and writing tar, cpio, zip, ISO, and other archive formats"
3HOMEPAGE = "http://www.libarchive.org/"
4SECTION = "devel"
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=ed99aca006bc346974bb745a35336425"
7
8DEPENDS = "e2fsprogs-native"
9
10PACKAGECONFIG ?= "zlib bz2"
11
12PACKAGECONFIG_append_class-target = "\
13 libxml2 \
14 ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \
15 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'xattr', '', d)} \
16 ${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
17"
18
19PACKAGECONFIG_append_class-nativesdk = " largefile"
20
21PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
22PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
23PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
24PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib,"
25PACKAGECONFIG[bz2] = "--with-bz2lib,--without-bz2lib,bzip2,"
26PACKAGECONFIG[xz] = "--with-lzmadec --with-lzma,--without-lzmadec --without-lzma,xz,"
27PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl,"
28PACKAGECONFIG[libxml2] = "--with-xml2,--without-xml2,libxml2,"
29PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat,"
30PACKAGECONFIG[lzo] = "--with-lzo2,--without-lzo2,lzo,"
31PACKAGECONFIG[nettle] = "--with-nettle,--without-nettle,nettle,"
32PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4,"
33
34SRC_URI = "http://libarchive.org/downloads/libarchive-${PV}.tar.gz \
35 "
36
37SRC_URI[md5sum] = "1ec00b7dcaf969dd2a5712f85f23c764"
38SRC_URI[sha256sum] = "691c194ee132d1f0f7a42541f091db811bc2e56f7107e9121be2bc8c04f1060f"
39
40inherit autotools update-alternatives pkgconfig
41
42CPPFLAGS += "-I${WORKDIR}/extra-includes"
43
44do_configure[cleandirs] += "${WORKDIR}/extra-includes"
45do_configure_prepend() {
46 # We just need the headers for some type constants, so no need to
47 # build all of e2fsprogs for the target
48 cp -R ${STAGING_INCDIR_NATIVE}/ext2fs ${WORKDIR}/extra-includes/
49}
50
51ALTERNATIVE_PRIORITY = "100"
52
53PACKAGES =+ "bsdtar"
54FILES_bsdtar = "${bindir}/bsdtar"
55
56ALTERNATIVE_bsdtar = "tar"
57ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
58ALTERNATIVE_TARGET[tar] = "${bindir}/bsdtar"
59
60PACKAGES =+ "bsdcpio"
61FILES_bsdcpio = "${bindir}/bsdcpio"
62
63ALTERNATIVE_bsdcpio = "cpio"
64ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
65ALTERNATIVE_TARGET[cpio] = "${bindir}/bsdcpio"
66
67BBCLASSEXTEND = "native nativesdk"