summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/iptables/iptables_1.8.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/iptables/iptables_1.8.10.bb')
-rw-r--r--meta/recipes-extended/iptables/iptables_1.8.10.bb123
1 files changed, 123 insertions, 0 deletions
diff --git a/meta/recipes-extended/iptables/iptables_1.8.10.bb b/meta/recipes-extended/iptables/iptables_1.8.10.bb
new file mode 100644
index 0000000000..5a87897742
--- /dev/null
+++ b/meta/recipes-extended/iptables/iptables_1.8.10.bb
@@ -0,0 +1,123 @@
1SUMMARY = "Tools for managing kernel packet filtering capabilities"
2DESCRIPTION = "iptables is the userspace command line program used to configure and control network packet \
3filtering code in Linux."
4HOMEPAGE = "http://www.netfilter.org/"
5BUGTRACKER = "http://bugzilla.netfilter.org/"
6LICENSE = "GPL-2.0-or-later"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://iptables/iptables.c;beginline=13;endline=25;md5=c5cffd09974558cf27d0f763df2a12dc \
9"
10
11SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.xz \
12 file://iptables.service \
13 file://iptables.rules \
14 file://ip6tables.service \
15 file://ip6tables.rules \
16 file://0001-configure-Add-option-to-enable-disable-libnfnetlink.patch \
17 file://0002-iptables-xshared.h-add-missing-sys.types.h-include.patch \
18 file://0004-configure.ac-only-check-conntrack-when-libnfnetlink-.patch \
19 "
20SRC_URI[sha256sum] = "5cc255c189356e317d070755ce9371eb63a1b783c34498fb8c30264f3cc59c9c"
21
22SYSTEMD_SERVICE:${PN} = "\
23 iptables.service \
24 ${@bb.utils.contains('PACKAGECONFIG', 'ipv6', 'ip6tables.service', '', d)} \
25"
26
27inherit autotools pkgconfig systemd
28
29EXTRA_OECONF = "--with-kernel=${STAGING_INCDIR}"
30
31CFLAGS:append:libc-musl = " -D__UAPI_DEF_ETHHDR=0"
32
33PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
34PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
35
36# libnfnetlink recipe is in meta-networking layer
37PACKAGECONFIG[libnfnetlink] = "--enable-libnfnetlink,--disable-libnfnetlink,libnfnetlink libnetfilter-conntrack"
38
39# libnftnl recipe is in meta-networking layer(previously known as libnftables)
40PACKAGECONFIG[libnftnl] = "--enable-nftables,--disable-nftables,libnftnl"
41
42do_configure:prepend() {
43 # Remove some libtool m4 files
44 # Keep ax_check_linker_flags.m4 which belongs to autoconf-archive.
45 rm -f libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4
46
47 # Copy a header to fix out of tree builds
48 cp -f ${S}/libiptc/linux_list.h ${S}/include/libiptc/
49}
50
51IPTABLES_RULES_DIR ?= "${sysconfdir}/${BPN}"
52
53do_install:append() {
54 install -d ${D}${IPTABLES_RULES_DIR}
55 install -m 0644 ${UNPACKDIR}/iptables.rules ${D}${IPTABLES_RULES_DIR}
56
57 install -d ${D}${systemd_system_unitdir}
58 install -m 0644 ${UNPACKDIR}/iptables.service ${D}${systemd_system_unitdir}
59
60 sed -i \
61 -e 's,@SBINDIR@,${sbindir},g' \
62 -e 's,@RULESDIR@,${IPTABLES_RULES_DIR},g' \
63 ${D}${systemd_system_unitdir}/iptables.service
64
65 if ${@bb.utils.contains('PACKAGECONFIG', 'ipv6', 'true', 'false', d)} ; then
66 install -m 0644 ${UNPACKDIR}/ip6tables.rules ${D}${IPTABLES_RULES_DIR}
67 install -m 0644 ${UNPACKDIR}/ip6tables.service ${D}${systemd_system_unitdir}
68
69 sed -i \
70 -e 's,@SBINDIR@,${sbindir},g' \
71 -e 's,@RULESDIR@,${IPTABLES_RULES_DIR},g' \
72 ${D}${systemd_system_unitdir}/ip6tables.service
73 fi
74
75 # if libnftnl is included, make the iptables symlink point to the nft-based binary by default
76 if ${@bb.utils.contains('PACKAGECONFIG', 'libnftnl', 'true', 'false', d)} ; then
77 ln -sf ${sbindir}/xtables-nft-multi ${D}${sbindir}/iptables
78 fi
79}
80
81PACKAGES =+ "${PN}-modules ${PN}-apply"
82PACKAGES_DYNAMIC += "^${PN}-module-.*"
83
84python populate_packages:prepend() {
85 modules = do_split_packages(d, '${libdir}/xtables', r'lib(.*)\.so$', '${PN}-module-%s', '${PN} module %s', extra_depends='')
86 if modules:
87 metapkg = d.getVar('PN') + '-modules'
88 d.appendVar('RDEPENDS:' + metapkg, ' ' + ' '.join(modules))
89}
90
91RDEPENDS:${PN} = "${PN}-module-xt-standard"
92RRECOMMENDS:${PN} = " \
93 ${PN}-modules \
94 kernel-module-x-tables \
95 kernel-module-ip-tables \
96 kernel-module-iptable-filter \
97 kernel-module-iptable-nat \
98 kernel-module-nf-defrag-ipv4 \
99 kernel-module-nf-conntrack \
100 kernel-module-nf-conntrack-ipv4 \
101 kernel-module-nf-nat \
102 kernel-module-ipt-masquerade \
103 ${@bb.utils.contains('PACKAGECONFIG', 'ipv6', '\
104 kernel-module-ip6table-filter \
105 kernel-module-ip6-tables \
106 ', '', d)} \
107"
108
109FILES:${PN} += "${datadir}/xtables"
110
111FILES:${PN}-apply = "${sbindir}/ip*-apply"
112RDEPENDS:${PN}-apply = "${PN} bash"
113
114# Include the symlinks as well in respective packages
115FILES:${PN}-module-xt-conntrack += "${libdir}/xtables/libxt_state.so"
116FILES:${PN}-module-xt-ct += "${libdir}/xtables/libxt_NOTRACK.so ${libdir}/xtables/libxt_REDIRECT.so"
117FILES:${PN}-module-xt-nat += "${libdir}/xtables/libxt_SNAT.so ${libdir}/xtables/libxt_DNAT.so ${libdir}/xtables/libxt_MASQUERADE.so"
118
119ALLOW_EMPTY:${PN}-modules = "1"
120
121INSANE_SKIP:${PN}-module-xt-conntrack = "dev-so"
122INSANE_SKIP:${PN}-module-xt-ct = "dev-so"
123INSANE_SKIP:${PN}-module-xt-nat = "dev-so"