summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/iptables/iptables_1.8.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/iptables/iptables_1.8.10.bb')
-rw-r--r--meta/recipes-extended/iptables/iptables_1.8.10.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta/recipes-extended/iptables/iptables_1.8.10.bb b/meta/recipes-extended/iptables/iptables_1.8.10.bb
index cd2f3bce0b..86f1335ac8 100644
--- a/meta/recipes-extended/iptables/iptables_1.8.10.bb
+++ b/meta/recipes-extended/iptables/iptables_1.8.10.bb
@@ -14,8 +14,6 @@ SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.xz \
14 file://ip6tables.service \ 14 file://ip6tables.service \
15 file://ip6tables.rules \ 15 file://ip6tables.rules \
16 file://0001-configure-Add-option-to-enable-disable-libnfnetlink.patch \ 16 file://0001-configure-Add-option-to-enable-disable-libnfnetlink.patch \
17 file://0002-iptables-xshared.h-add-missing-sys.types.h-include.patch \
18 file://0004-configure.ac-only-check-conntrack-when-libnfnetlink-.patch \
19 " 17 "
20SRC_URI[sha256sum] = "5cc255c189356e317d070755ce9371eb63a1b783c34498fb8c30264f3cc59c9c" 18SRC_URI[sha256sum] = "5cc255c189356e317d070755ce9371eb63a1b783c34498fb8c30264f3cc59c9c"
21 19
@@ -34,7 +32,7 @@ PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
34PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," 32PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
35 33
36# libnfnetlink recipe is in meta-networking layer 34# libnfnetlink recipe is in meta-networking layer
37PACKAGECONFIG[libnfnetlink] = "--enable-libnfnetlink,--disable-libnfnetlink,libnfnetlink libnetfilter-conntrack" 35PACKAGECONFIG[libnfnetlink] = "--enable-libnfnetlink --enable-connlabel,--disable-libnfnetlink --disable-connlabel,libnfnetlink libnetfilter-conntrack"
38 36
39# libnftnl recipe is in meta-networking layer(previously known as libnftables) 37# libnftnl recipe is in meta-networking layer(previously known as libnftables)
40PACKAGECONFIG[libnftnl] = "--enable-nftables,--disable-nftables,libnftnl" 38PACKAGECONFIG[libnftnl] = "--enable-nftables,--disable-nftables,libnftnl"
@@ -52,10 +50,10 @@ IPTABLES_RULES_DIR ?= "${sysconfdir}/${BPN}"
52 50
53do_install:append() { 51do_install:append() {
54 install -d ${D}${IPTABLES_RULES_DIR} 52 install -d ${D}${IPTABLES_RULES_DIR}
55 install -m 0644 ${WORKDIR}/iptables.rules ${D}${IPTABLES_RULES_DIR} 53 install -m 0644 ${UNPACKDIR}/iptables.rules ${D}${IPTABLES_RULES_DIR}
56 54
57 install -d ${D}${systemd_system_unitdir} 55 install -d ${D}${systemd_system_unitdir}
58 install -m 0644 ${WORKDIR}/iptables.service ${D}${systemd_system_unitdir} 56 install -m 0644 ${UNPACKDIR}/iptables.service ${D}${systemd_system_unitdir}
59 57
60 sed -i \ 58 sed -i \
61 -e 's,@SBINDIR@,${sbindir},g' \ 59 -e 's,@SBINDIR@,${sbindir},g' \
@@ -63,8 +61,8 @@ do_install:append() {
63 ${D}${systemd_system_unitdir}/iptables.service 61 ${D}${systemd_system_unitdir}/iptables.service
64 62
65 if ${@bb.utils.contains('PACKAGECONFIG', 'ipv6', 'true', 'false', d)} ; then 63 if ${@bb.utils.contains('PACKAGECONFIG', 'ipv6', 'true', 'false', d)} ; then
66 install -m 0644 ${WORKDIR}/ip6tables.rules ${D}${IPTABLES_RULES_DIR} 64 install -m 0644 ${UNPACKDIR}/ip6tables.rules ${D}${IPTABLES_RULES_DIR}
67 install -m 0644 ${WORKDIR}/ip6tables.service ${D}${systemd_system_unitdir} 65 install -m 0644 ${UNPACKDIR}/ip6tables.service ${D}${systemd_system_unitdir}
68 66
69 sed -i \ 67 sed -i \
70 -e 's,@SBINDIR@,${sbindir},g' \ 68 -e 's,@SBINDIR@,${sbindir},g' \
@@ -75,6 +73,8 @@ do_install:append() {
75 # if libnftnl is included, make the iptables symlink point to the nft-based binary by default 73 # if libnftnl is included, make the iptables symlink point to the nft-based binary by default
76 if ${@bb.utils.contains('PACKAGECONFIG', 'libnftnl', 'true', 'false', d)} ; then 74 if ${@bb.utils.contains('PACKAGECONFIG', 'libnftnl', 'true', 'false', d)} ; then
77 ln -sf ${sbindir}/xtables-nft-multi ${D}${sbindir}/iptables 75 ln -sf ${sbindir}/xtables-nft-multi ${D}${sbindir}/iptables
76 ln -sf ${sbindir}/xtables-nft-multi ${D}${sbindir}/iptables-save
77 ln -sf ${sbindir}/xtables-nft-multi ${D}${sbindir}/iptables-restore
78 fi 78 fi
79} 79}
80 80