summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/images/core-image-testcontroller-initramfs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/images/core-image-testcontroller-initramfs.bb')
-rw-r--r--meta/recipes-extended/images/core-image-testcontroller-initramfs.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-extended/images/core-image-testcontroller-initramfs.bb b/meta/recipes-extended/images/core-image-testcontroller-initramfs.bb
new file mode 100644
index 0000000000..3b81afd7c0
--- /dev/null
+++ b/meta/recipes-extended/images/core-image-testcontroller-initramfs.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Small image capable of booting a device with custom install scripts, \
2adding a second rootfs, used for testing."
3
4# use -testfs live-install scripts
5PACKAGE_INSTALL = "initramfs-live-boot initramfs-live-install-testfs initramfs-live-install-efi-testfs busybox udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
6
7# Do not pollute the initrd image with rootfs features
8IMAGE_FEATURES = ""
9
10IMAGE_NAME_SUFFIX ?= ""
11IMAGE_LINGUAS = ""
12
13LICENSE = "MIT"
14
15IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
16inherit core-image
17
18IMAGE_ROOTFS_SIZE = "8192"
19IMAGE_ROOTFS_EXTRA_SPACE = "0"
20BAD_RECOMMENDATIONS += "busybox-syslog"
21
22# Use the same restriction as initramfs-live-install-testfs
23COMPATIBLE_HOST = "(i.86|x86_64).*-linux"