summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/hdparm/hdparm_9.56.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/hdparm/hdparm_9.56.bb')
-rw-r--r--meta/recipes-extended/hdparm/hdparm_9.56.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-extended/hdparm/hdparm_9.56.bb b/meta/recipes-extended/hdparm/hdparm_9.56.bb
new file mode 100644
index 0000000000..17932ad223
--- /dev/null
+++ b/meta/recipes-extended/hdparm/hdparm_9.56.bb
@@ -0,0 +1,43 @@
1SUMMARY = "Utility for viewing/manipulating IDE disk drive/driver parameters"
2HOMEPAGE = "http://sourceforge.net/projects/hdparm/"
3DESCRIPTION = "hdparm is a Linux shell utility for viewing \
4and manipulating various IDE drive and driver parameters."
5SECTION = "console/utils"
6
7LICENSE = "BSD & GPLv2"
8LICENSE_${PN} = "BSD"
9LICENSE_${PN}-dbg = "BSD"
10LICENSE_wiper = "GPLv2"
11
12LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=495d03e50dc6c89d6a30107ab0df5b03 \
13 file://debian/copyright;md5=a82d7ba3ade9e8ec902749db98c592f3 \
14 file://wiper/GPLv2.txt;md5=fcb02dc552a041dee27e4b85c7396067 \
15 file://wiper/wiper.sh;beginline=7;endline=31;md5=b7bc642addc152ea307505bf1a296f09"
16
17
18PACKAGES =+ "wiper"
19
20FILES_wiper = "${bindir}/wiper.sh"
21
22RDEPENDS_wiper = "bash gawk coreutils"
23
24SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/${BP}.tar.gz \
25 file://wiper.sh-fix-stat-path.patch \
26 "
27
28SRC_URI[md5sum] = "7900608e32834f65d2654fdb696e71a0"
29SRC_URI[sha256sum] = "6ff9ed695f1017396eec4101f990f114b7b0e0a04c5aa6369c0394053d16e4da"
30
31EXTRA_OEMAKE = 'STRIP="echo" LDFLAGS="${LDFLAGS}"'
32
33inherit update-alternatives
34
35ALTERNATIVE_${PN} = "hdparm"
36ALTERNATIVE_LINK_NAME[hdparm] = "${base_sbindir}/hdparm"
37ALTERNATIVE_PRIORITY = "100"
38
39do_install () {
40 install -d ${D}/${base_sbindir} ${D}/${mandir}/man8 ${D}/${bindir}
41 oe_runmake 'DESTDIR=${D}' 'sbindir=${base_sbindir}' install
42 cp ${S}/wiper/wiper.sh ${D}/${bindir}
43}