summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/gzip/gzip_1.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/gzip/gzip_1.8.bb')
-rw-r--r--meta/recipes-extended/gzip/gzip_1.8.bb20
1 files changed, 19 insertions, 1 deletions
diff --git a/meta/recipes-extended/gzip/gzip_1.8.bb b/meta/recipes-extended/gzip/gzip_1.8.bb
index 11be846b21..a0dec143db 100644
--- a/meta/recipes-extended/gzip/gzip_1.8.bb
+++ b/meta/recipes-extended/gzip/gzip_1.8.bb
@@ -2,7 +2,9 @@ require gzip.inc
2 2
3LICENSE = "GPLv3+" 3LICENSE = "GPLv3+"
4 4
5SRC_URI = "${GNU_MIRROR}/gzip/${BP}.tar.gz" 5SRC_URI = "${GNU_MIRROR}/gzip/${BP}.tar.gz \
6 file://0001-gzip-port-zdiff-zless-to-Busybox.patch \
7 file://run-ptest"
6SRC_URI_append_class-target = " file://wrong-path-fix.patch" 8SRC_URI_append_class-target = " file://wrong-path-fix.patch"
7 9
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ 10LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
@@ -12,6 +14,22 @@ PROVIDES_append_class-native = " gzip-replacement-native"
12 14
13BBCLASSEXTEND = "native" 15BBCLASSEXTEND = "native"
14 16
17inherit ptest
18
19do_install_ptest() {
20 mkdir -p ${D}${PTEST_PATH}/src/build-aux
21 cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/src/build-aux/
22 mkdir -p ${D}${PTEST_PATH}/src/tests
23 cp -r ${S}/tests/* ${D}${PTEST_PATH}/src/tests
24 sed -e 's/^abs_srcdir = ..*/abs_srcdir = \.\./' \
25 -e 's/^top_srcdir = ..*/top_srcdir = \.\./' \
26 -e 's/^GREP = ..*/GREP = grep/' \
27 -e 's/^AWK = ..*/AWK = awk/' \
28 -e 's/^srcdir = ..*/srcdir = \./' \
29 -e 's/^Makefile: ..*/Makefile: /' \
30 ${B}/tests/Makefile > ${D}${PTEST_PATH}/src/tests/Makefile
31}
32
15SRC_URI[md5sum] = "732553152814b22dc35aa0267df5286c" 33SRC_URI[md5sum] = "732553152814b22dc35aa0267df5286c"
16SRC_URI[sha256sum] = "1ff7aedb3d66a0d73f442f6261e4b3860df6fd6c94025c2cb31a202c9c60fe0e" 34SRC_URI[sha256sum] = "1ff7aedb3d66a0d73f442f6261e4b3860df6fd6c94025c2cb31a202c9c60fe0e"
17 35