summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ghostscript/ghostscript_9.53.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/ghostscript/ghostscript_9.53.3.bb')
-rw-r--r--meta/recipes-extended/ghostscript/ghostscript_9.53.3.bb125
1 files changed, 0 insertions, 125 deletions
diff --git a/meta/recipes-extended/ghostscript/ghostscript_9.53.3.bb b/meta/recipes-extended/ghostscript/ghostscript_9.53.3.bb
deleted file mode 100644
index cbf60c8c85..0000000000
--- a/meta/recipes-extended/ghostscript/ghostscript_9.53.3.bb
+++ /dev/null
@@ -1,125 +0,0 @@
1SUMMARY = "The GPL Ghostscript PostScript/PDF interpreter"
2DESCRIPTION = "Ghostscript is used for PostScript/PDF preview and printing. Usually as \
3a back-end to a program such as ghostview, it can display PostScript and PDF \
4documents in an X11 environment. \
5\
6Furthermore, it can render PostScript and PDF files as graphics to be printed \
7on non-PostScript printers. Supported printers include common \
8dot-matrix, inkjet and laser models. \
9"
10HOMEPAGE = "http://www.ghostscript.com"
11SECTION = "console/utils"
12
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=70dc2bac4d0ce4448da873cd86b123fc"
15
16DEPENDS = "ghostscript-native tiff jpeg fontconfig cups libpng"
17DEPENDS_class-native = "libpng-native"
18
19UPSTREAM_CHECK_URI = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases"
20UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
21
22def gs_verdir(v):
23 return "".join(v.split("."))
24
25
26SRC_URI_BASE = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${@gs_verdir("${PV}")}/${BPN}-${PV}.tar.gz \
27 file://ghostscript-9.15-parallel-make.patch \
28 file://ghostscript-9.16-Werror-return-type.patch \
29 file://do-not-check-local-libpng-source.patch \
30 file://avoid-host-contamination.patch \
31 file://mkdir-p.patch \
32"
33
34SRC_URI = "${SRC_URI_BASE} \
35 file://ghostscript-9.21-prevent_recompiling.patch \
36 file://cups-no-gcrypt.patch \
37 "
38
39SRC_URI_class-native = "${SRC_URI_BASE} \
40 file://ghostscript-9.21-native-fix-disable-system-libtiff.patch \
41 file://base-genht.c-add-a-preprocessor-define-to-allow-fope.patch \
42 "
43
44SRC_URI[sha256sum] = "6eaf422f26a81854a230b80fd18aaef7e8d94d661485bd2e97e695b9dce7bf7f"
45
46# Put something like
47#
48# PACKAGECONFIG_append_pn-ghostscript = " x11"
49#
50# in local.conf to enable building with X11. Be careful. The order
51# of the overrides matters!
52#
53#PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
54PACKAGECONFIG_class-native = ""
55
56PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}, \
57 --without-x, virtual/libx11 libxext libxt gtk+3\
58 "
59
60EXTRA_OECONF = "--without-libpaper --with-system-libtiff --without-jbig2dec \
61 --with-fontpath=${datadir}/fonts \
62 --without-libidn --with-cups-serverbin=${exec_prefix}/lib/cups \
63 --with-cups-datadir=${datadir}/cups \
64 CUPSCONFIG="${STAGING_BINDIR_CROSS}/cups-config" \
65 "
66
67EXTRA_OECONF_append_mipsarcho32 = " --with-large_color_index=0"
68
69# Explicity disable libtiff, fontconfig,
70# freetype, cups for ghostscript-native
71EXTRA_OECONF_class-native = "--without-x --with-system-libtiff=no \
72 --without-jbig2dec --without-libpaper \
73 --with-fontpath=${datadir}/fonts \
74 --without-libidn --disable-fontconfig \
75 --enable-freetype --disable-cups "
76
77# This has been fixed upstream but for now we need to subvert the check for time.h
78# http://bugs.ghostscript.com/show_bug.cgi?id=692443
79# http://bugs.ghostscript.com/show_bug.cgi?id=692426
80CFLAGS += "-DHAVE_SYS_TIME_H=1"
81BUILD_CFLAGS += "-DHAVE_SYS_TIME_H=1"
82
83inherit autotools-brokensep
84
85do_configure_prepend_class-target () {
86 rm -rf ${S}/jpeg/
87}
88
89do_configure_append () {
90 # copy tools from the native ghostscript build
91 if [ "${PN}" != "ghostscript-native" ]; then
92 mkdir -p obj/aux soobj
93 for i in genarch genconf mkromfs echogs gendev genht packps; do
94 cp ${STAGING_BINDIR_NATIVE}/ghostscript-${PV}/$i obj/aux/$i
95 done
96 fi
97}
98
99do_install_append () {
100 mkdir -p ${D}${datadir}/ghostscript/${PV}/
101 cp -r ${S}/Resource ${D}${datadir}/ghostscript/${PV}/
102 cp -r ${S}/iccprofiles ${D}${datadir}/ghostscript/${PV}/
103}
104
105do_compile_class-native () {
106 mkdir -p obj
107 for i in genarch genconf mkromfs echogs gendev genht packps; do
108 oe_runmake obj/aux/$i
109 done
110}
111
112do_install_class-native () {
113 install -d ${D}${bindir}/ghostscript-${PV}
114 for i in genarch genconf mkromfs echogs gendev genht packps; do
115 install -m 755 obj/aux/$i ${D}${bindir}/ghostscript-${PV}/$i
116 done
117}
118
119BBCLASSEXTEND = "native"
120
121# ghostscript does not supports "arc"
122COMPATIBLE_HOST = "^(?!arc).*"
123
124# some entries in NVD uses gpl_ghostscript
125CVE_PRODUCT = "ghostscript gpl_ghostscript"