summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/findutils/findutils_4.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/findutils/findutils_4.9.0.bb')
-rw-r--r--meta/recipes-extended/findutils/findutils_4.9.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-extended/findutils/findutils_4.9.0.bb b/meta/recipes-extended/findutils/findutils_4.9.0.bb
new file mode 100644
index 0000000000..074817df27
--- /dev/null
+++ b/meta/recipes-extended/findutils/findutils_4.9.0.bb
@@ -0,0 +1,27 @@
1require findutils.inc
2
3# GPL-2.0-or-later (<< 4.2.32), GPL-3.0-or-later (>= 4.2.32)
4LICENSE = "GPL-3.0-or-later"
5LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
6
7DEPENDS = "bison-native"
8
9SRC_URI[sha256sum] = "a2bfb8c09d436770edc59f50fa483e785b161a3b7b9d547573cb08065fd462fe"
10
11PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux"
12# http://savannah.gnu.org/bugs/?27299
13CACHED_CONFIGUREVARS += "gl_cv_func_wcwidth_works=yes"
14
15EXTRA_OECONF += "ac_cv_path_SORT=${bindir}/sort"
16
17# need od from coreutils for -t option
18RDEPENDS:${PN}-ptest += "bash sed grep coreutils"
19
20do_install_ptest:class-target() {
21 mkdir -p ${D}${PTEST_PATH}/tests/
22 cp -r ${S}/tests/* ${D}${PTEST_PATH}/tests/
23
24 # substitute value in run-ptest with actual version
25 sed -i -e 's/__run_ptest_version__/${PV}/' ${D}${PTEST_PATH}/run-ptest
26
27}