summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_3.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_3.13.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_3.13.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_3.13.bb b/meta/recipes-extended/ethtool/ethtool_3.13.bb
new file mode 100644
index 0000000000..adcb6db86d
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_3.13.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Display or change ethernet card settings"
2DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
3HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
4SECTION = "console/network"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
8
9SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
10 file://run-ptest"
11
12SRC_URI[md5sum] = "0c0c0558a403b478cd3f65dadc00470d"
13SRC_URI[sha256sum] = "68f6b6c9417e8ff3d3b5a8bc22fc4fe8846176ee7d7636e365ce6a2e7b1e44e9"
14
15inherit autotools ptest
16RDEPENDS_${PN}-ptest += "make"
17
18do_compile_ptest() {
19 oe_runmake test-cmdline test-features
20}
21
22do_install_ptest () {
23 cp ${B}/Makefile ${D}${PTEST_PATH}
24 install ${B}/test-cmdline ${D}${PTEST_PATH}
25 install ${B}/test-features ${D}${PTEST_PATH}
26 install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
27 sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
28}