summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ed/ed_1.20.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/ed/ed_1.20.1.bb')
-rw-r--r--meta/recipes-extended/ed/ed_1.20.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-extended/ed/ed_1.20.1.bb b/meta/recipes-extended/ed/ed_1.20.1.bb
new file mode 100644
index 0000000000..9ae53002c3
--- /dev/null
+++ b/meta/recipes-extended/ed/ed_1.20.1.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Line-oriented text editor"
2HOMEPAGE = "http://www.gnu.org/software/ed/"
3DESCRIPTION = "GNU ed is a line-oriented text editor. It is used to create, display, modify and otherwise manipulate text files, both interactively and via shell scripts. A restricted version of ed, red, can only edit files in the current directory and cannot execute shell commands."
4
5LICENSE = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=76d6e300ffd8fb9d18bd9b136a9bba13 \
7 file://ed.h;endline=20;md5=c3212b6c53b09668107420af9368c0ef \
8 file://main.c;endline=17;md5=e5d2ae5ddd1ecb87dc71702c06dd06dc \
9 "
10
11SECTION = "base"
12
13CVE_PRODUCT = "gnu:ed"
14
15# LSB states that ed should be in /bin/
16bindir = "${base_bindir}"
17
18# Upstream regularly removes previous releases from https://ftp.gnu.org/gnu/ed/
19SRC_URI = "${GNU_MIRROR}/ed/${BP}.tar.lz"
20UPSTREAM_CHECK_URI = "${GNU_MIRROR}/ed/"
21
22SRC_URI[sha256sum] = "b1a463b297a141f9876c4b1fcd01477f645cded92168090e9a35db2af4babbca"
23
24EXTRA_OEMAKE = "-e MAKEFLAGS="
25
26inherit texinfo
27
28do_configure() {
29 ${S}/configure
30}
31
32do_install() {
33 oe_runmake 'DESTDIR=${D}' install
34 # Info dir listing isn't interesting at this point so remove it if it exists.
35 if [ -e "${D}${infodir}/dir" ]; then
36 rm -f ${D}${infodir}/dir
37 fi
38}