summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/cronie/cronie_1.4.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/cronie/cronie_1.4.7.bb')
-rw-r--r--meta/recipes-extended/cronie/cronie_1.4.7.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta/recipes-extended/cronie/cronie_1.4.7.bb b/meta/recipes-extended/cronie/cronie_1.4.7.bb
new file mode 100644
index 0000000000..7d6093a470
--- /dev/null
+++ b/meta/recipes-extended/cronie/cronie_1.4.7.bb
@@ -0,0 +1,64 @@
1SUMMARY = "Cron daemon for executing programs at set times"
2DESCRIPTION = "Cronie contains the standard UNIX daemon crond that runs \
3specified programs at scheduled times and related tools. It is based on the \
4original cron and has security and configuration enhancements like the \
5ability to use pam and SELinux."
6HOMEPAGE = "https://fedorahosted.org/cronie/"
7BUGTRACKER = "mmaslano@redhat.com"
8
9# Internet Systems Consortium License
10LICENSE = "ISC license & BSD"
11LIC_FILES_CHKSUM = "file://COPYING;md5=963ea0772a2adbdcd607a9b2ec320c11 \
12 file://src/cron.h;endline=20;md5=b425c334265026177128353a142633b4 \
13 file://src/popen.c;beginline=3;endline=31;md5=edd50742d8def712e9472dba353668a9"
14
15SECTION = "utils"
16
17PR = "r1"
18
19SRC_URI = "https://fedorahosted.org/releases/c/r/cronie/cronie-${PV}.tar.gz \
20 file://crond.init \
21 file://crontab"
22
23SRC_URI[md5sum] = "dfc26c47756d0c40ee27ae3c7ee98e0d"
24SRC_URI[sha256sum] = "83bae15ae5504454ba74f4142f5db3aa22be594327fea19d2534f65803137fbd"
25
26inherit autotools update-rc.d
27
28INITSCRIPT_NAME = "crond"
29INITSCRIPT_PARAMS = "start 90 2 3 4 5 . stop 60 0 1 6 ."
30
31do_install_append () {
32 install -d ${D}${sysconfdir}/sysconfig/
33 install -d ${D}${sysconfdir}/init.d/
34 install -m 0644 ${S}/crond.sysconfig ${D}${sysconfdir}/sysconfig/crond
35 install -m 0755 ${WORKDIR}/crond.init ${D}${sysconfdir}/init.d/crond
36
37 # below are necessary for a complete cron environment
38 install -d ${D}${localstatedir}/spool/cron
39 install -m 0755 ${WORKDIR}/crontab ${D}${sysconfdir}/
40 mkdir -p ${D}${sysconfdir}/cron.d
41 mkdir -p ${D}${sysconfdir}/cron.hourly
42 mkdir -p ${D}${sysconfdir}/cron.daily
43 mkdir -p ${D}${sysconfdir}/cron.weekly
44 mkdir -p ${D}${sysconfdir}/cron.monthly
45}
46
47pkg_postinst_${PN} () {
48 if [ "x$D" != "x" ] ; then
49 exit 1
50 fi
51
52 # below setting is necessary to allow normal user using crontab
53
54 # add 'crontab' group and setgid for crontab binary
55 grep crontab /etc/group || addgroup crontab
56 chown root:crontab /usr/bin/crontab
57 chmod 2755 /usr/bin/crontab
58
59 # allow 'crontab' group write to /var/spool/cron
60 chown root:crontab /var/spool/cron
61 chmod 770 /var/spool/cron
62
63 chmod 600 /etc/crontab
64}