summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/cronie/cronie_1.4.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/cronie/cronie_1.4.11.bb')
-rw-r--r--meta/recipes-extended/cronie/cronie_1.4.11.bb73
1 files changed, 73 insertions, 0 deletions
diff --git a/meta/recipes-extended/cronie/cronie_1.4.11.bb b/meta/recipes-extended/cronie/cronie_1.4.11.bb
new file mode 100644
index 0000000000..5b124482a3
--- /dev/null
+++ b/meta/recipes-extended/cronie/cronie_1.4.11.bb
@@ -0,0 +1,73 @@
1SUMMARY = "Cron daemon for executing programs at set times"
2DESCRIPTION = "Cronie contains the standard UNIX daemon crond that runs \
3specified programs at scheduled times and related tools. It is based on the \
4original cron and has security and configuration enhancements like the \
5ability to use pam and SELinux."
6HOMEPAGE = "https://fedorahosted.org/cronie/"
7BUGTRACKER = "mmaslano@redhat.com"
8
9# Internet Systems Consortium License
10LICENSE = "ISC & BSD"
11LIC_FILES_CHKSUM = "file://COPYING;md5=963ea0772a2adbdcd607a9b2ec320c11 \
12 file://src/cron.c;endline=20;md5=b425c334265026177128353a142633b4 \
13 file://src/popen.c;beginline=3;endline=31;md5=edd50742d8def712e9472dba353668a9"
14
15SECTION = "utils"
16
17DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
18RDEPENDS_${PN} = "${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_DEPS}', '', d)}"
19PAM_DEPS = "libpam libpam-runtime pam-plugin-access pam-plugin-loginuid"
20
21SRC_URI = "https://fedorahosted.org/releases/c/r/cronie/cronie-${PV}.tar.gz \
22 file://crond.init \
23 file://crontab \
24 ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}"
25
26PAM_SRC_URI = "file://crond_pam_config.patch"
27
28
29SRC_URI[md5sum] = "2ba645cf54de17f138ef70312843862f"
30SRC_URI[sha256sum] = "fd08084cedddbb42499f80ddb7f2158195c3555c2ff40ee11d4ece2f9864d7be"
31
32inherit autotools update-rc.d useradd
33
34EXTRA_OECONF += "\
35 ${@base_contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)}"
36
37INITSCRIPT_NAME = "crond"
38INITSCRIPT_PARAMS = "start 90 2 3 4 5 . stop 60 0 1 6 ."
39
40USERADD_PACKAGES = "${PN}"
41GROUPADD_PARAM_${PN} = "--system crontab"
42
43do_install_append () {
44 install -d ${D}${sysconfdir}/sysconfig/
45 install -d ${D}${sysconfdir}/init.d/
46 install -m 0644 ${S}/crond.sysconfig ${D}${sysconfdir}/sysconfig/crond
47 install -m 0755 ${WORKDIR}/crond.init ${D}${sysconfdir}/init.d/crond
48
49 # below are necessary for a complete cron environment
50 install -d ${D}${localstatedir}/spool/cron
51 install -m 0755 ${WORKDIR}/crontab ${D}${sysconfdir}/
52 mkdir -p ${D}${sysconfdir}/cron.d
53 mkdir -p ${D}${sysconfdir}/cron.hourly
54 mkdir -p ${D}${sysconfdir}/cron.daily
55 mkdir -p ${D}${sysconfdir}/cron.weekly
56 mkdir -p ${D}${sysconfdir}/cron.monthly
57 touch ${D}${sysconfdir}/cron.deny
58
59 # below setting is necessary to allow normal user using crontab
60
61 # setgid for crontab binary
62 chown root:crontab ${D}${bindir}/crontab
63 chmod 2755 ${D}${bindir}/crontab
64
65 # allow 'crontab' group write to /var/spool/cron
66 chown root:crontab ${D}${localstatedir}/spool/cron
67 chmod 770 ${D}${localstatedir}/spool/cron
68
69 chmod 600 ${D}${sysconfdir}/crontab
70}
71
72FILES_${PN} += "${sysconfdir}/cron*"
73