summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/cpio/cpio_2.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/cpio/cpio_2.14.bb')
-rw-r--r--meta/recipes-extended/cpio/cpio_2.14.bb89
1 files changed, 89 insertions, 0 deletions
diff --git a/meta/recipes-extended/cpio/cpio_2.14.bb b/meta/recipes-extended/cpio/cpio_2.14.bb
new file mode 100644
index 0000000000..e55fb70cb1
--- /dev/null
+++ b/meta/recipes-extended/cpio/cpio_2.14.bb
@@ -0,0 +1,89 @@
1SUMMARY = "GNU cpio is a program to manage archives of files"
2DESCRIPTION = "GNU cpio is a tool for creating and extracting archives, or copying files from one place to \
3another. It handles a number of cpio formats as well as reading and writing tar files."
4HOMEPAGE = "http://www.gnu.org/software/cpio/"
5SECTION = "base"
6LICENSE = "GPL-3.0-only"
7LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
8
9SRC_URI = "${GNU_MIRROR}/cpio/cpio-${PV}.tar.gz \
10 file://0001-configure-Include-needed-header-for-major-minor-macr.patch \
11 file://run-ptest \
12 file://test.sh \
13 "
14
15SRC_URI[sha256sum] = "145a340fd9d55f0b84779a44a12d5f79d77c99663967f8cfa168d7905ca52454"
16
17inherit autotools gettext texinfo ptest
18
19# Issue applies to use of cpio in SUSE/OBS, doesn't apply to us
20CVE_CHECK_IGNORE += "CVE-2010-4226"
21
22EXTRA_OECONF += "DEFAULT_RMT_DIR=${sbindir}"
23
24do_install () {
25 autotools_do_install
26 if [ "${base_bindir}" != "${bindir}" ]; then
27 install -d ${D}${base_bindir}/
28 mv "${D}${bindir}/cpio" "${D}${base_bindir}/cpio"
29 if [ "${sbindir}" != "${bindir}" ]; then
30 rmdir ${D}${bindir}/
31 fi
32 fi
33
34 # Avoid conflicts with the version from tar
35 mv "${D}${mandir}/man8/rmt.8" "${D}${mandir}/man8/rmt-cpio.8"
36}
37
38do_compile_ptest() {
39 oe_runmake -C ${B}/gnu/ check
40 oe_runmake -C ${B}/lib/ check
41 oe_runmake -C ${B}/rmt/ check
42 oe_runmake -C ${B}/src/ check
43 oe_runmake -C ${B}/tests/ genfile
44}
45
46do_install_ptest() {
47 install -d ${D}${PTEST_PATH}/tests/
48 sed -i "/abs_/d" ${B}/tests/atconfig
49 install --mode=755 ${B}/tests/atconfig ${D}${PTEST_PATH}/tests/
50 sed -i "s%${B}/tests:%%g" ${B}/tests/atlocal
51 sed -i "s%${B}/src:%%g" ${B}/tests/atlocal
52 install --mode=755 ${B}/tests/atlocal ${D}${PTEST_PATH}/tests/
53 install --mode=755 ${B}/tests/genfile ${D}${PTEST_PATH}/tests/
54 install --mode=755 ${S}/tests/testsuite ${D}${PTEST_PATH}/tests/
55 install --mode=755 ${WORKDIR}/test.sh ${D}${PTEST_PATH}/test.sh
56 sed -i "s#@PTEST_PATH@#${PTEST_PATH}#g" ${D}${PTEST_PATH}/test.sh
57}
58
59# ptest.bbclass currently chowns the ptest directory explicitly, so we need to
60# change permission after that has happened so the ptest user can write a
61# temporary directory.
62do_install_ptest_base:append() {
63 chgrp -R ptest ${D}${PTEST_PATH}/
64 chmod -R g+w ${D}${PTEST_PATH}/
65}
66
67# The tests need to run as a non-root user, so pull in the ptest user
68DEPENDS:append:class-target = "${@bb.utils.contains('PTEST_ENABLED', '1', ' ptest-runner', '', d)}"
69PACKAGE_WRITE_DEPS += "ptest-runner"
70
71RDEPENDS:${PN}-ptest += "ptest-runner"
72
73PACKAGES =+ "${PN}-rmt"
74
75FILES:${PN}-rmt = "${sbindir}/rmt*"
76
77inherit update-alternatives
78
79ALTERNATIVE_PRIORITY = "100"
80
81ALTERNATIVE:${PN} = "cpio"
82ALTERNATIVE:${PN}-rmt = "rmt"
83
84ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
85
86ALTERNATIVE_PRIORITY[rmt] = "50"
87ALTERNATIVE_LINK_NAME[rmt] = "${sbindir}/rmt"
88
89BBCLASSEXTEND = "native nativesdk"