summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/chkconfig/chkconfig-alternatives-native_1.3.59.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/chkconfig/chkconfig-alternatives-native_1.3.59.bb')
-rw-r--r--meta/recipes-extended/chkconfig/chkconfig-alternatives-native_1.3.59.bb44
1 files changed, 0 insertions, 44 deletions
diff --git a/meta/recipes-extended/chkconfig/chkconfig-alternatives-native_1.3.59.bb b/meta/recipes-extended/chkconfig/chkconfig-alternatives-native_1.3.59.bb
deleted file mode 100644
index 87fa8eb605..0000000000
--- a/meta/recipes-extended/chkconfig/chkconfig-alternatives-native_1.3.59.bb
+++ /dev/null
@@ -1,44 +0,0 @@
1require recipes-extended/chkconfig/chkconfig_1.3.58.bb
2
3SUMMARY = "${SUMMARY_chkconfig-alternatives}"
4DESCRIPTION = "${DESCRIPTION_chkconfig-alternatives}"
5DEPENDS = ""
6PROVIDES += "virtual/update-alternatives-native"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8
9# The sysroot branch is 1.3.59 + some git commits from master + --sysroot
10# support for alternatives.
11SRC_URI = "git://github.com/kergoth/chkconfig;branch=sysroot"
12S = "${WORKDIR}/git"
13UPSTREAM_CHECK_GITTAGREGEX = "chkconfig-(?P<pver>(\d+(\.\d+)+))"
14
15SRCREV = "cd437ecbd8986c894442f8fce1e0061e20f04dee"
16PV = "1.3.59+${SRCPV}"
17
18inherit native
19
20# We want our native recipes to build using the target paths rather than paths
21# into the sysroot, as we may use them to construct the rootfs. As such, we
22# only adjust the paths to match the metadata for the target, not native.
23obey_variables () {
24 sed -i 's,ALTERNATIVES_ROOT,OPKG_OFFLINE_ROOT,' ${S}/alternatives.c
25}
26
27do_compile () {
28 oe_runmake alternatives
29}
30
31do_install () {
32 install -d ${D}${sysconfdir}/alternatives \
33 ${D}${localstatedir}/lib/alternatives
34
35 install -D -m 0755 alternatives ${D}${bindir}/alternatives
36 install -D -m 0644 alternatives.8 ${D}${mandir}/man8/alternatives.8
37
38 ln -s alternatives ${D}${bindir}/update-alternatives
39 ln -s alternatives.8 ${D}${mandir}/man8/update-alternatives.8
40}
41
42do_install_append_linuxstdbase() {
43 rm -rf ${D}${libdir}/lsb
44}