summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bzip2/bzip2_1.0.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/bzip2/bzip2_1.0.8.bb')
-rw-r--r--meta/recipes-extended/bzip2/bzip2_1.0.8.bb32
1 files changed, 16 insertions, 16 deletions
diff --git a/meta/recipes-extended/bzip2/bzip2_1.0.8.bb b/meta/recipes-extended/bzip2/bzip2_1.0.8.bb
index 70eb67f1f2..4e3a06f240 100644
--- a/meta/recipes-extended/bzip2/bzip2_1.0.8.bb
+++ b/meta/recipes-extended/bzip2/bzip2_1.0.8.bb
@@ -4,14 +4,14 @@ Huffman coding. Compression is generally considerably better than that achieved
4LZ77/LZ78-based compressors, and approaches the performance of the PPM family of statistical compressors." 4LZ77/LZ78-based compressors, and approaches the performance of the PPM family of statistical compressors."
5HOMEPAGE = "https://sourceware.org/bzip2/" 5HOMEPAGE = "https://sourceware.org/bzip2/"
6SECTION = "console/utils" 6SECTION = "console/utils"
7LICENSE = "bzip2-1.0.6 & GPLv3+ & Apache-2.0 & MS-PL & BSD-3-Clause & Zlib" 7LICENSE = "bzip2-1.0.6 & GPL-3.0-or-later & Apache-2.0 & MS-PL & BSD-3-Clause & Zlib"
8LICENSE_${PN} = "bzip2-1.0.6" 8LICENSE:${PN} = "bzip2-1.0.6"
9LICENSE_${PN}-dev = "bzip2-1.0.6" 9LICENSE:${PN}-dev = "bzip2-1.0.6"
10LICENSE_${PN}-dbg = "bzip2-1.0.6" 10LICENSE:${PN}-dbg = "bzip2-1.0.6"
11LICENSE_${PN}-doc = "bzip2-1.0.6" 11LICENSE:${PN}-doc = "bzip2-1.0.6"
12LICENSE_${PN}-src = "bzip2-1.0.6" 12LICENSE:${PN}-src = "bzip2-1.0.6"
13LICENSE_libbz2 = "bzip2-1.0.6" 13LICENSE:libbz2 = "bzip2-1.0.6"
14LICENSE_${PN}-ptest = "bzip2-1.0.6 & GPLv3+ & Apache-2.0 & MS-PL & BSD-3-Clause & Zlib" 14LICENSE:${PN}-ptest = "bzip2-1.0.6 & GPL-3.0-or-later & Apache-2.0 & MS-PL & BSD-3-Clause & Zlib"
15 15
16LIC_FILES_CHKSUM = "file://LICENSE;beginline=4;endline=37;md5=600af43c50f1fcb82e32f19b32df4664 \ 16LIC_FILES_CHKSUM = "file://LICENSE;beginline=4;endline=37;md5=600af43c50f1fcb82e32f19b32df4664 \
17 file://${WORKDIR}/git/commons-compress/LICENSE.txt;md5=86d3f3a95c324c9479bd8986968f4327 \ 17 file://${WORKDIR}/git/commons-compress/LICENSE.txt;md5=86d3f3a95c324c9479bd8986968f4327 \
@@ -22,7 +22,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;beginline=4;endline=37;md5=600af43c50f1fcb82e
22" 22"
23 23
24SRC_URI = "https://sourceware.org/pub/${BPN}/${BPN}-${PV}.tar.gz \ 24SRC_URI = "https://sourceware.org/pub/${BPN}/${BPN}-${PV}.tar.gz \
25 git://sourceware.org/git/bzip2-tests.git;name=bzip2-tests \ 25 git://sourceware.org/git/bzip2-tests.git;name=bzip2-tests;branch=master;protocol=https \
26 file://configure.ac;subdir=${BP} \ 26 file://configure.ac;subdir=${BP} \
27 file://Makefile.am;subdir=${BP} \ 27 file://Makefile.am;subdir=${BP} \
28 file://run-ptest \ 28 file://run-ptest \
@@ -36,17 +36,17 @@ UPSTREAM_CHECK_URI = "https://www.sourceware.org/pub/bzip2/"
36 36
37PACKAGES =+ "libbz2" 37PACKAGES =+ "libbz2"
38 38
39CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64" 39CFLAGS:append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"
40 40
41inherit autotools update-alternatives ptest relative_symlinks 41inherit autotools update-alternatives ptest relative_symlinks
42 42
43ALTERNATIVE_PRIORITY = "100" 43ALTERNATIVE_PRIORITY = "100"
44ALTERNATIVE_${PN} = "bunzip2 bzcat bzip2" 44ALTERNATIVE:${PN} = "bunzip2 bzcat bzip2"
45 45
46#install binaries to bzip2-native under sysroot for replacement-native 46#install binaries to bzip2-native under sysroot for replacement-native
47EXTRA_OECONF_append_class-native = " --bindir=${STAGING_BINDIR_NATIVE}/${PN}" 47EXTRA_OECONF:append:class-native = " --bindir=${STAGING_BINDIR_NATIVE}/${PN}"
48 48
49do_configure_prepend () { 49do_configure:prepend () {
50 sed -i -e "s|%BZIP2_VERSION%|${PV}|" ${S}/configure.ac 50 sed -i -e "s|%BZIP2_VERSION%|${PV}|" ${S}/configure.ac
51} 51}
52 52
@@ -62,9 +62,9 @@ do_install_ptest () {
62 sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile 62 sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile
63} 63}
64 64
65FILES_libbz2 = "${libdir}/lib*${SOLIBS}" 65FILES:libbz2 = "${libdir}/lib*${SOLIBS}"
66 66
67RDEPENDS_${PN}-ptest += "make bash" 67RDEPENDS:${PN}-ptest += "make bash"
68 68
69PROVIDES_append_class-native = " bzip2-replacement-native" 69PROVIDES:append:class-native = " bzip2-replacement-native"
70BBCLASSEXTEND = "native nativesdk" 70BBCLASSEXTEND = "native nativesdk"