summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bzip2/bzip2_1.0.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/bzip2/bzip2_1.0.7.bb')
-rw-r--r--meta/recipes-extended/bzip2/bzip2_1.0.7.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-extended/bzip2/bzip2_1.0.7.bb b/meta/recipes-extended/bzip2/bzip2_1.0.7.bb
new file mode 100644
index 0000000000..02e9d9ef07
--- /dev/null
+++ b/meta/recipes-extended/bzip2/bzip2_1.0.7.bb
@@ -0,0 +1,42 @@
1SUMMARY = "Very high-quality data compression program"
2DESCRIPTION = "bzip2 compresses files using the Burrows-Wheeler block-sorting text compression algorithm, and \
3Huffman coding. Compression is generally considerably better than that achieved by more conventional \
4LZ77/LZ78-based compressors, and approaches the performance of the PPM family of statistical compressors."
5HOMEPAGE = "https://sourceware.org/bzip2/"
6SECTION = "console/utils"
7LICENSE = "bzip2"
8LIC_FILES_CHKSUM = "file://LICENSE;beginline=4;endline=37;md5=39406315f540c69bd05b1531daedd2ae"
9
10SRC_URI = "https://sourceware.org/pub/${BPN}/${BPN}-${PV}.tar.gz \
11 file://configure.ac;subdir=${BP} \
12 file://Makefile.am;subdir=${BP} \
13 file://run-ptest \
14 "
15SRC_URI[md5sum] = "1a6a61cc867be4f3d6549037a09bf13e"
16SRC_URI[sha256sum] = "e768a87c5b1a79511499beb41500bcc4caf203726fff46a6f5f9ad27fe08ab2b"
17
18UPSTREAM_CHECK_URI = "https://www.sourceware.org/pub/bzip2/"
19UPSTREAM_VERSION_UNKNOWN = "1"
20
21PACKAGES =+ "libbz2"
22
23CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"
24
25inherit autotools update-alternatives ptest relative_symlinks
26
27ALTERNATIVE_PRIORITY = "100"
28ALTERNATIVE_${PN} = "bunzip2 bzcat bzip2"
29
30#install binaries to bzip2-native under sysroot for replacement-native
31EXTRA_OECONF_append_class-native = " --bindir=${STAGING_BINDIR_NATIVE}/${PN}"
32
33do_install_ptest () {
34 sed -i -e "s|^Makefile:|_Makefile:|" ${D}${PTEST_PATH}/Makefile
35}
36
37FILES_libbz2 = "${libdir}/lib*${SOLIBS}"
38
39RDEPENDS_${PN}-ptest += "make"
40
41PROVIDES_append_class-native = " bzip2-replacement-native"
42BBCLASSEXTEND = "native nativesdk"