summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/at/at_3.2.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/at/at_3.2.5.bb')
-rw-r--r--meta/recipes-extended/at/at_3.2.5.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-extended/at/at_3.2.5.bb b/meta/recipes-extended/at/at_3.2.5.bb
index c0c876a644..112d1c4adc 100644
--- a/meta/recipes-extended/at/at_3.2.5.bb
+++ b/meta/recipes-extended/at/at_3.2.5.bb
@@ -55,22 +55,22 @@ SYSTEMD_SERVICE:${PN} = "atd.service"
55do_patch[postfuncs] += "copy_posix_files" 55do_patch[postfuncs] += "copy_posix_files"
56 56
57copy_posix_files() { 57copy_posix_files() {
58 cp -f ${WORKDIR}/posixtm.[ch] ${S} 58 cp -f ${UNPACKDIR}/posixtm.[ch] ${S}
59} 59}
60 60
61do_install () { 61do_install () {
62 oe_runmake -e "IROOT=${D}" install 62 oe_runmake -e "IROOT=${D}" install
63 63
64 install -d ${D}${sysconfdir}/init.d 64 install -d ${D}${sysconfdir}/init.d
65 install -m 0755 ${WORKDIR}/atd.init ${D}${sysconfdir}/init.d/atd 65 install -m 0755 ${UNPACKDIR}/atd.init ${D}${sysconfdir}/init.d/atd
66 66
67 # install systemd unit files 67 # install systemd unit files
68 install -d ${D}${systemd_system_unitdir} 68 install -d ${D}${systemd_system_unitdir}
69 install -m 0644 ${WORKDIR}/atd.service ${D}${systemd_system_unitdir} 69 install -m 0644 ${UNPACKDIR}/atd.service ${D}${systemd_system_unitdir}
70 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_system_unitdir}/atd.service 70 sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_system_unitdir}/atd.service
71 71
72 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" ]; then 72 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" ]; then
73 install -D -m 0644 ${WORKDIR}/${BP}/pam.conf ${D}${sysconfdir}/pam.d/atd 73 install -D -m 0644 ${S}/pam.conf ${D}${sysconfdir}/pam.d/atd
74 fi 74 fi
75 rm -f ${D}${datadir}/at/batch-job 75 rm -f ${D}${datadir}/at/batch-job
76} 76}