summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/at/at_3.1.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/at/at_3.1.14.bb')
-rw-r--r--meta/recipes-extended/at/at_3.1.14.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-extended/at/at_3.1.14.bb b/meta/recipes-extended/at/at_3.1.14.bb
new file mode 100644
index 0000000000..f80b620e68
--- /dev/null
+++ b/meta/recipes-extended/at/at_3.1.14.bb
@@ -0,0 +1,63 @@
1SUMMARY = "Delayed job execution and batch processing"
2DESCRIPTION = "At allows for commands to be run at a particular time. Batch will execute commands when \
3the system load levels drop to a particular level."
4SECTION = "base"
5LICENSE="GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
7DEPENDS = "flex flex-native \
8 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
9
10VIRTUAL-RUNTIME_initscripts ?= "initscripts"
11RDEPENDS_${PN} = "${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_DEPS}', '', d)} \
12 ${VIRTUAL-RUNTIME_initscripts} \
13"
14
15PAM_DEPS = "libpam libpam-runtime pam-plugin-env pam-plugin-limits"
16
17RCONFLICTS_${PN} = "atd"
18RREPLACES_${PN} = "atd"
19
20SRC_URI = "${DEBIAN_MIRROR}/main/a/at/at_${PV}.orig.tar.gz \
21 file://fix_parallel_build_error.patch \
22 file://posixtm.c \
23 file://posixtm.h \
24 file://file_replacement_with_gplv2.patch \
25 file://S99at \
26 ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}"
27
28PAM_SRC_URI = "file://pam.conf.patch \
29 file://configure-add-enable-pam.patch"
30
31SRC_URI[md5sum] = "d41cfd79033b6e49a8838add59a42ac6"
32SRC_URI[sha256sum] = "cd092bf05d29c25b286f55a960ce8b8c3c5beb571d86ed8eb1dfb3b61291b3ae"
33
34EXTRA_OECONF += "ac_cv_path_SENDMAIL=/bin/true \
35 --with-daemon_username=root \
36 --with-daemon_groupname=root \
37 --with-jobdir=/var/spool/at/jobs \
38 --with-atspool=/var/spool/at/spool \
39 ac_cv_header_security_pam_appl_h=${@base_contains('DISTRO_FEATURES', 'pam', 'yes', 'no', d)} "
40
41inherit autotools
42
43PARALLEL_MAKE = ""
44
45do_compile_prepend () {
46 cp -f ${WORKDIR}/posixtm.[ch] ${S}
47}
48
49do_install () {
50 oe_runmake -e "IROOT=${D}" install
51
52 install -d ${D}${sysconfdir}/init.d
53 install -d ${D}${sysconfdir}/rcS.d
54 install -m 0755 ${WORKDIR}/S99at ${D}${sysconfdir}/init.d/atd
55 ln -sf ../init.d/atd ${D}${sysconfdir}/rcS.d/S99at
56
57 for feature in ${DISTRO_FEATURES}; do
58 if [ "$feature" = "pam" ]; then
59 install -D -m 0644 ${WORKDIR}/${BP}/pam.conf ${D}${sysconfdir}/pam.d/atd
60 break
61 fi
62 done
63}