summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/at/at_3.1.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/at/at_3.1.12.bb')
-rw-r--r--meta/recipes-extended/at/at_3.1.12.bb64
1 files changed, 0 insertions, 64 deletions
diff --git a/meta/recipes-extended/at/at_3.1.12.bb b/meta/recipes-extended/at/at_3.1.12.bb
deleted file mode 100644
index f2017b77f9..0000000000
--- a/meta/recipes-extended/at/at_3.1.12.bb
+++ /dev/null
@@ -1,64 +0,0 @@
1SUMMARY = "Delayed job execution and batch processing"
2DESCRIPTION = "At allows for commands to be run at a particular time. Batch will execute commands when \
3the system load levels drop to a particular level."
4SECTION = "base"
5LICENSE="GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
7DEPENDS = "flex initscripts \
8 ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
9RDEPENDS_${PN} = "${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_DEPS}', '', d)}"
10PAM_DEPS = "libpam libpam-runtime pam-plugin-env pam-plugin-limits"
11
12RCONFLICTS_${PN} = "atd"
13RREPLACES_${PN} = "atd"
14PR = "r7"
15
16SRC_URI = "${DEBIAN_MIRROR}/main/a/at/at_${PV}.orig.tar.gz \
17 file://configure.patch \
18 file://use-ldflags.patch \
19 file://nonstripbinaries.patch \
20 file://fix_parallel_build_error.patch \
21 file://posixtm.c \
22 file://posixtm.h \
23 file://file_replacement_with_gplv2.patch \
24 file://S99at \
25 ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}"
26
27PAM_SRC_URI = "file://pam.conf.patch \
28 file://configure-add-enable-pam.patch"
29
30SRC_URI[md5sum] = "1e67991776148fb319fd77a2e599a765"
31SRC_URI[sha256sum] = "7c55c6ab4fbe8add9e68f31b2b0ebf3fe805c9a4e7cfb2623a3d8a4789cc18f3"
32
33EXTRA_OECONF += "ac_cv_path_SENDMAIL=/bin/true \
34 --with-daemon_username=root \
35 --with-daemon_groupname=root \
36 --with-jobdir=/var/spool/at/jobs \
37 --with-atspool=/var/spool/at/spool \
38 ${@base_contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)} "
39
40inherit autotools
41
42do_compile_prepend () {
43 cp -f ${WORKDIR}/posixtm.[ch] ${S}
44}
45
46do_install () {
47 oe_runmake "IROOT=${D}" install
48
49 install -d ${D}${sysconfdir}/init.d
50 install -d ${D}${sysconfdir}/rcS.d
51 install -m 0755 ${WORKDIR}/S99at ${D}${sysconfdir}/init.d/atd
52 ln -sf ../init.d/atd ${D}${sysconfdir}/rcS.d/S99at
53 cp -r ${D}/usr/doc/at ${D}${docdir}/
54 rm -rf ${D}/usr/doc
55
56 for feature in ${DISTRO_FEATURES}; do
57 if [ "$feature" = "pam" ]; then
58 install -D -m 0644 ${WORKDIR}/${P}/pam.conf ${D}${sysconfdir}/pam.d/atd
59 break
60 fi
61 done
62}
63
64PARALLEL_MAKE = ""