summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/acpica/acpica_20240322.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/acpica/acpica_20240322.bb')
-rw-r--r--meta/recipes-extended/acpica/acpica_20240322.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-extended/acpica/acpica_20240322.bb b/meta/recipes-extended/acpica/acpica_20240322.bb
new file mode 100644
index 0000000000..90e3599d32
--- /dev/null
+++ b/meta/recipes-extended/acpica/acpica_20240322.bb
@@ -0,0 +1,49 @@
1SUMMARY = "ACPICA tools for the development and debug of ACPI tables"
2DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \
3OS-independent reference implementation of the Advanced Configuration and \
4Power Interface Specification (ACPI). ACPICA code contains those portions of \
5ACPI meant to be directly integrated into the host OS as a kernel-resident \
6subsystem, and a small set of tools to assist in developing and debugging \
7ACPI tables."
8
9HOMEPAGE = "https://www.intel.com/content/www/us/en/developer/topic-technology/open/acpica/overview.html"
10SECTION = "console/tools"
11
12LICENSE = "Intel | BSD-3-Clause | GPL-2.0-only"
13LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=05eb845b15a27440410f456adc2ed082"
14
15COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
16
17DEPENDS = "m4-native flex-native bison-native"
18
19SRC_URI = "git://github.com/acpica/acpica;protocol=https;branch=master"
20SRCREV = "170fc3076a86777077637f10b05c32ac21ac13aa"
21
22S = "${WORKDIR}/git"
23
24inherit update-alternatives
25
26ALTERNATIVE_PRIORITY = "100"
27ALTERNATIVE:${PN} = "acpixtract acpidump"
28
29EXTRA_OEMAKE = "CC='${CC}' \
30 OPT_CFLAGS=-Wall \
31 DESTDIR=${D} \
32 PREFIX=${prefix} \
33 INSTALLDIR=${bindir} \
34 INSTALLFLAGS= \
35 YACC=bison \
36 YFLAGS='-y --file-prefix-map=${WORKDIR}=${TARGET_DBGSRC_DIR}' \
37 "
38
39do_install() {
40 oe_runmake install
41}
42
43# iasl*.bb is a subset of this recipe, so RREPLACE it
44PROVIDES = "iasl"
45RPROVIDES:${PN} += "iasl"
46RREPLACES:${PN} += "iasl"
47RCONFLICTS:${PN} += "iasl"
48
49BBCLASSEXTEND = "native nativesdk"