summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/xmlto/xmlto_0.0.25.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/xmlto/xmlto_0.0.25.bb')
-rw-r--r--meta/recipes-devtools/xmlto/xmlto_0.0.25.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/xmlto/xmlto_0.0.25.bb b/meta/recipes-devtools/xmlto/xmlto_0.0.25.bb
new file mode 100644
index 0000000000..2698b1c258
--- /dev/null
+++ b/meta/recipes-devtools/xmlto/xmlto_0.0.25.bb
@@ -0,0 +1,38 @@
1SUMMARY = "A shell-script tool for converting XML files to various formats"
2HOMEPAGE = "https://fedorahosted.org/xmlto/"
3SECTION = "docs/xmlto"
4LICENSE = "GPLv2"
5
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
7
8SRC_URI = "https://fedorahosted.org/releases/x/m/xmlto/xmlto-${PV}.tar.gz \
9 file://obsolete_automake_macros.patch \
10 file://configure.in-drop-the-test-of-xmllint-and-xsltproc.patch \
11 file://catalog.xml \
12"
13SRC_URI[md5sum] = "a88cd3f08789b4825d1ac89fa065170d"
14SRC_URI[sha256sum] = "c52b56d929e8d20fc19cd3b7ec238f8d039730c56ee311cc352e843147e3e31a"
15
16inherit autotools
17
18# xmlto needs getopt/xmllint/xsltproc/bash at runtime
19RDEPENDS_${PN} = "docbook-xml-dtd4 \
20 docbook-xsl-stylesheets \
21 util-linux \
22 libxml2 \
23 bash \
24"
25RDEPENDS_${PN}_append_class-target = " \
26 libxslt-bin \
27"
28
29BBCLASSEXTEND = "native"
30
31EXTRA_OECONF_append = " XMLLINT=xmllint XSLTPROC=xsltproc"
32
33do_install_append() {
34 install -d ${D}${sysconfdir}/xml/
35 install -m 755 ${WORKDIR}/catalog.xml ${D}${sysconfdir}/xml/catalog.xml
36 create_wrapper ${D}/${bindir}/xmlto XML_CATALOG_FILES=${sysconfdir}/xml/catalog.xml
37}
38