summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/valgrind/valgrind_3.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/valgrind/valgrind_3.9.0.bb')
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.9.0.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.9.0.bb b/meta/recipes-devtools/valgrind/valgrind_3.9.0.bb
new file mode 100644
index 0000000000..64da1a2808
--- /dev/null
+++ b/meta/recipes-devtools/valgrind/valgrind_3.9.0.bb
@@ -0,0 +1,44 @@
1SUMMARY = "Valgrind memory debugger and instrumentation framework"
2HOMEPAGE = "http://valgrind.org/"
3BUGTRACKER = "http://valgrind.org/support/bug_reports.html"
4LICENSE = "GPLv2 & GPLv2+ & BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=c46082167a314d785d012a244748d803 \
6 file://include/pub_tool_basics.h;beginline=1;endline=29;md5=e7071929a50d4b0fc27a3014b315b0f7 \
7 file://include/valgrind.h;beginline=1;endline=56;md5=92df8a1bde56fe2af70931ff55f6622f \
8 file://COPYING.DOCS;md5=8fdeb5abdb235a08e76835f8f3260215"
9
10X11DEPENDS = "virtual/libx11"
11DEPENDS = "${@base_contains('DISTRO_FEATURES', 'x11', '${X11DEPENDS}', '', d)}"
12PR = "r8"
13
14SRC_URI = "http://www.valgrind.org/downloads/valgrind-${PV}.tar.bz2 \
15 file://fixed-perl-path.patch \
16 file://Added-support-for-PPC-instructions-mfatbu-mfatbl.patch \
17 file://sepbuildfix.patch \
18 file://glibc-2.19.patch \
19 "
20
21SRC_URI[md5sum] = "0947de8112f946b9ce64764af7be6df2"
22SRC_URI[sha256sum] = "e6af71a06bc2534541b07743e1d58dc3caf744f38205ca3e5b5a0bdf372ed6f0"
23
24COMPATIBLE_HOST = '(i.86|x86_64|powerpc|powerpc64).*-linux'
25COMPATIBLE_HOST_armv7a = 'arm.*-linux'
26
27inherit autotools
28
29EXTRA_OECONF = "--enable-tls --without-mpicc"
30EXTRA_OECONF_armv7a = "--enable-tls -host=armv7-none-linux-gnueabi --without-mpicc"
31EXTRA_OEMAKE = "-w"
32PARALLEL_MAKE = ""
33
34do_install_append () {
35 install -m 644 ${B}/default.supp ${D}/${libdir}/valgrind/
36}
37
38RDEPENDS_${PN} += "perl"
39
40FILES_${PN}-dbg += "${libdir}/${PN}/*/.debug/*"
41
42# valgrind needs debug information for ld.so at runtime in order to
43# redirect functions like strlen.
44RRECOMMENDS_${PN} += "${TCLIBC}-dbg"