summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/valgrind/valgrind_3.22.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/valgrind/valgrind_3.22.0.bb')
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.22.0.bb276
1 files changed, 276 insertions, 0 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.22.0.bb b/meta/recipes-devtools/valgrind/valgrind_3.22.0.bb
new file mode 100644
index 0000000000..563d99f0e2
--- /dev/null
+++ b/meta/recipes-devtools/valgrind/valgrind_3.22.0.bb
@@ -0,0 +1,276 @@
1SUMMARY = "Valgrind memory debugger and instrumentation framework"
2HOMEPAGE = "http://valgrind.org/"
3DESCRIPTION = "Valgrind is an instrumentation framework for building dynamic analysis tools. There are Valgrind tools that can automatically detect many memory management and threading bugs, and profile your programs in detail."
4BUGTRACKER = "http://valgrind.org/support/bug_reports.html"
5LICENSE = "GPL-2.0-only & GPL-2.0-or-later & BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://include/pub_tool_basics.h;beginline=6;endline=29;md5=41c410e8d3f305aee7aaa666b2e4f366 \
8 file://include/valgrind.h;beginline=1;endline=56;md5=ad3b317f3286b6b704575d9efe6ca5df \
9 file://COPYING.DOCS;md5=24ea4c7092233849b4394699333b5c56"
10
11DEPENDS = " \
12 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'boost', '', d)} \
13 "
14
15SRC_URI = "https://sourceware.org/pub/valgrind/valgrind-${PV}.tar.bz2 \
16 file://fixed-perl-path.patch \
17 file://Added-support-for-PPC-instructions-mfatbu-mfatbl.patch \
18 file://run-ptest \
19 file://remove-for-aarch64 \
20 file://remove-for-all \
21 file://taskset_nondeterministic_tests \
22 file://0005-Modify-vg_test-wrapper-to-support-PTEST-formats.patch \
23 file://use-appropriate-march-mcpu-mfpu-for-ARM-test-apps.patch \
24 file://avoid-neon-for-targets-which-don-t-support-it.patch \
25 file://valgrind-make-ld-XXX.so-strlen-intercept-optional.patch \
26 file://0001-makefiles-Drop-setting-mcpu-to-cortex-a8-on-arm-arch.patch \
27 file://0001-sigqueue-Rename-_sifields-to-__si_fields-on-musl.patch \
28 file://0003-correct-include-directive-path-for-config.h.patch \
29 file://0001-Return-a-valid-exit_code-from-vg_regtest.patch \
30 file://0001-valgrind-filter_xml_frames-do-not-filter-usr.patch \
31 file://0001-memcheck-vgtests-remove-fullpath-after-flags.patch \
32 file://s390x_vec_op_t.patch \
33 file://0001-none-tests-fdleak_cmsg.stderr.exp-adjust-tmp-paths.patch \
34 file://0001-memcheck-tests-Fix-timerfd-syscall-test.patch \
35 file://0001-docs-Disable-manual-validation.patch \
36 file://0001-valgrind-monitor.py-regular-expressions-should-use-r.patch \
37 file://0002-Bug-476548-valgrind-3.22.0-fails-on-assertion-when-l.patch \
38 file://0003-Add-fchmodat2-syscall-on-linux.patch \
39 file://0004-Bug-478624-Valgrind-incompatibility-with-binutils-2..patch \
40 "
41SRC_URI[sha256sum] = "c811db5add2c5f729944caf47c4e7a65dcaabb9461e472b578765dd7bf6d2d4c"
42UPSTREAM_CHECK_REGEX = "valgrind-(?P<pver>\d+(\.\d+)+)\.tar"
43
44COMPATIBLE_HOST = '(i.86|x86_64|arm|aarch64|mips|powerpc|powerpc64).*-linux'
45
46# patch 0001-memcheck-vgtests-remove-fullpath-after-flags.patch removes relative path
47# argument. Change expected stderr files accordingly.
48do_patch:append() {
49 bb.build.exec_func('do_sed_paths', d)
50}
51
52do_sed_paths() {
53 sed -i -e 's|tests/||' ${S}/memcheck/tests/badfree3.stderr.exp
54 sed -i -e 's|tests/||' ${S}/memcheck/tests/varinfo5.stderr.exp
55}
56
57# valgrind supports armv7 and above
58COMPATIBLE_HOST:armv4 = 'null'
59COMPATIBLE_HOST:armv5 = 'null'
60COMPATIBLE_HOST:armv6 = 'null'
61
62# valgrind fails with powerpc soft-float
63COMPATIBLE_HOST:powerpc = "${@bb.utils.contains('TARGET_FPU', 'soft', 'null', '.*-linux', d)}"
64
65# X32 isn't supported by valgrind at this time
66COMPATIBLE_HOST:linux-gnux32 = 'null'
67COMPATIBLE_HOST:linux-muslx32 = 'null'
68
69# Disable for some MIPS variants
70COMPATIBLE_HOST:mipsarchr6 = 'null'
71COMPATIBLE_HOST:linux-gnun32 = 'null'
72
73# Disable for powerpc64 with musl
74COMPATIBLE_HOST:libc-musl:powerpc64 = 'null'
75
76# brokenseip is unfortunately required by ptests to pass
77inherit autotools-brokensep ptest multilib_header
78
79EXTRA_OECONF = "--enable-tls --without-mpicc"
80EXTRA_OECONF += "${@['--enable-only32bit','--enable-only64bit'][d.getVar('SITEINFO_BITS') != '32']}"
81
82# valgrind checks host_cpu "armv7*)", so we need to over-ride the autotools.bbclass default --host option
83EXTRA_OECONF:append:arm = " --host=armv7${HOST_VENDOR}-${HOST_OS}"
84
85EXTRA_OEMAKE = "-w"
86
87CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
88
89# valgrind likes to control its own optimisation flags. It generally defaults
90# to -O2 but uses -O0 for some specific test apps etc. Passing our own flags
91# (via CFLAGS) means we interfere with that. Only pass DEBUG_FLAGS to it
92# which fixes build path issue in DWARF.
93SELECTED_OPTIMIZATION = "${DEBUG_FLAGS}"
94
95# Split out various helper scripts to separate packages to avoid the
96# main package depending on perl and python.
97PACKAGES =+ "${PN}-cachegrind ${PN}-massif ${PN}-callgrind"
98
99FILES:${PN}-cachegrind = "${bindir}/cg_*"
100FILES:${PN}-massif = "${bindir}/ms_*"
101FILES:${PN}-callgrind = "${bindir}/callgrind_*"
102
103RDEPENDS:${PN}-cachegrind = "${PN} python3-core"
104RDEPENDS:${PN}-massif = "${PN} perl"
105RDEPENDS:${PN}-callgrind = "${PN} perl"
106
107do_configure:prepend () {
108 rm -rf ${S}/config.h
109 sed -i -e 's:$(abs_top_builddir):$(pkglibdir)/ptest:g' ${S}/none/tests/Makefile.am
110 sed -i -e 's:$(top_builddir):$(pkglibdir)/ptest:g' ${S}/memcheck/tests/Makefile.am
111}
112
113do_install:append () {
114 install -m 644 ${B}/default.supp ${D}/${libexecdir}/valgrind/
115 oe_multilib_header valgrind/config.h
116}
117
118VALGRINDARCH ?= "${TARGET_ARCH}"
119VALGRINDARCH:aarch64 = "arm64"
120VALGRINDARCH:x86-64 = "amd64"
121VALGRINDARCH:x86 = "x86"
122VALGRINDARCH:mips = "mips32"
123VALGRINDARCH:mipsel = "mips32"
124VALGRINDARCH:mips64el = "mips64"
125VALGRINDARCH:powerpc = "ppc"
126VALGRINDARCH:powerpc64 = "ppc64"
127VALGRINDARCH:powerpc64le = "ppc64le"
128
129INHIBIT_PACKAGE_STRIP_FILES = "${PKGD}${libexecdir}/valgrind/vgpreload_memcheck-${VALGRINDARCH}-linux.so"
130
131# valgrind needs debug information for ld.so at runtime in order to
132# redirect functions like strlen.
133RRECOMMENDS:${PN} += "${TCLIBC}-dbg"
134
135RDEPENDS:${PN}-ptest += " bash coreutils curl file \
136 gdb \
137 ${TCLIBC}-src gcc-runtime-dbg \
138 libgomp \
139 perl \
140 perl-module-file-basename perl-module-file-glob perl-module-getopt-long \
141 perl-module-overloading perl-module-cwd perl-module-ipc-open3 \
142 perl-module-carp perl-module-symbol \
143 procps \
144 python3-compile \
145 sed \
146 util-linux-taskset \
147 ${PN}-dbg ${PN}-src \
148 ${PN}-cachegrind ${PN}-massif ${PN}-callgrind \
149"
150RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-utils glibc-gconv-utf-32"
151
152# One of the tests contains a bogus interpreter path on purpose.
153# Skip file dependency check
154SKIP_FILEDEPS:${PN}-ptest = '1'
155INSANE_SKIP:${PN}-ptest = "debug-deps"
156
157do_compile_ptest() {
158 oe_runmake check
159}
160
161
162do_install_ptest() {
163 chmod +x ${B}/tests/vg_regtest
164
165 # The test application binaries are not automatically installed.
166 # Grab them from the build directory.
167 #
168 # The regression tests require scripts and data files that are not
169 # copied to the build directory. They must be copied from the
170 # source directory.
171 saved_dir=$PWD
172 for parent_dir in ${S} ${B} ; do
173 cd $parent_dir
174
175 subdirs=" \
176 .in_place \
177 cachegrind/tests \
178 callgrind/tests \
179 dhat/tests \
180 drd/tests \
181 gdbserver_tests \
182 helgrind/tests \
183 lackey/tests \
184 massif/tests \
185 memcheck/tests \
186 none/tests \
187 tests \
188 exp-bbv/tests \
189 "
190 # Get the vg test scripts, filters, and expected files
191 for dir in $subdirs ; do
192 find $dir | cpio -pvdu ${D}${PTEST_PATH}
193 done
194 cd $saved_dir
195 done
196
197 # The scripts reference config.h so add it to the top ptest dir.
198 cp ${B}/config.h ${D}${PTEST_PATH}
199 install -D ${WORKDIR}/remove-for-aarch64 ${D}${PTEST_PATH}
200 install -D ${WORKDIR}/remove-for-all ${D}${PTEST_PATH}
201 install -D ${WORKDIR}/taskset_nondeterministic_tests ${D}${PTEST_PATH}
202
203 # Add an executable need by none/tests/bigcode
204 mkdir ${D}${PTEST_PATH}/perf
205 cp ${B}/perf/bigcode ${D}${PTEST_PATH}/perf
206
207 # Add an executable needed by memcheck/tests/vcpu_bz2
208 cp ${B}/perf/bz2 ${D}${PTEST_PATH}/perf
209
210 # Make the ptest dir look like the top level valgrind src dir
211 # This is checked by the gdbserver_tests/make_local_links script
212 mkdir ${D}${PTEST_PATH}/coregrind
213 cp ${B}/coregrind/vgdb ${D}${PTEST_PATH}/coregrind
214
215 # Add an executable needed by massif tests
216 cp ${B}/massif/ms_print ${D}${PTEST_PATH}/massif/ms_print
217
218 find ${D}${PTEST_PATH} \
219 \( \
220 -name "Makefile*" \
221 -o -name "*.o" \
222 \) \
223 -exec rm {} \;
224
225 sed -i s:\.\./\.\./callgrind/callgrind_annotate:${bindir}/callgrind_annotate: ${D}${PTEST_PATH}/callgrind/tests/ann1.vgtest
226 sed -i s:\.\./\.\./callgrind/callgrind_annotate:${bindir}/callgrind_annotate: ${D}${PTEST_PATH}/callgrind/tests/ann2.vgtest
227
228 # point the expanded @abs_top_builddir@ of the host to PTEST_PATH
229 sed -i s:${S}:${PTEST_PATH}:g \
230 ${D}${PTEST_PATH}/memcheck/tests/linux/debuginfod-check.vgtest
231
232 # handle multilib
233 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
234 sed -i s:@libexecdir@:${libexecdir}:g ${D}${PTEST_PATH}/run-ptest
235 sed -i s:@bindir@:${bindir}:g ${D}${PTEST_PATH}/run-ptest
236
237 # enable cachegrind ptests
238 ln -s ${bindir}/cg_annotate ${D}/${PTEST_PATH}/cachegrind/cg_annotate
239 ln -s ${bindir}/cg_diff ${D}/${PTEST_PATH}/cachegrind/cg_diff
240 ln -s ${bindir}/cg_merge ${D}/${PTEST_PATH}/cachegrind/cg_merge
241
242 # This test fails on the host as well, using both 3.15 and git master (as of Jan 24 2020)
243 # https://bugs.kde.org/show_bug.cgi?id=402833
244 rm ${D}${PTEST_PATH}/memcheck/tests/overlap.vgtest
245
246 # This is known failure see https://bugs.kde.org/show_bug.cgi?id=435732
247 rm ${D}${PTEST_PATH}/memcheck/tests/leak_cpp_interior.vgtest
248
249 # https://bugs.kde.org/show_bug.cgi?id=445743
250 rm ${D}${PTEST_PATH}/drd/tests/pth_mutex_signal
251
252 # As the binary isn't stripped or debug-splitted, the source file isn't fetched
253 # via dwarfsrcfiles either, so it needs to be installed manually.
254 mkdir -p ${D}${TARGET_DBGSRC_DIR}/none/tests/
255 install ${S}/none/tests/tls.c ${D}${TARGET_DBGSRC_DIR}/none/tests/
256}
257
258do_install_ptest:append:x86-64 () {
259 # https://bugs.kde.org/show_bug.cgi?id=463456
260 rm ${D}${PTEST_PATH}/memcheck/tests/origin6-fp.vgtest
261 # https://bugs.kde.org/show_bug.cgi?id=463458
262 rm ${D}${PTEST_PATH}/memcheck/tests/vcpu_fnfns.vgtest
263 # https://bugs.kde.org/show_bug.cgi?id=463463
264 rm ${D}${PTEST_PATH}/none/tests/amd64/fma.vgtest
265}
266
267# avoid stripping some generated binaries otherwise some of the tests will fail
268# run-strip-reloc.sh, run-strip-strmerge.sh and so on will fail
269INHIBIT_PACKAGE_STRIP_FILES += "\
270 ${PKGD}${PTEST_PATH}/none/tests/tls \
271 ${PKGD}${PTEST_PATH}/none/tests/tls.so \
272 ${PKGD}${PTEST_PATH}/none/tests/tls2.so \
273 ${PKGD}${PTEST_PATH}/helgrind/tests/tc09_bad_unlock \
274 ${PKGD}${PTEST_PATH}/memcheck/tests/manuel1 \
275 ${PKGD}${PTEST_PATH}/drd/tests/pth_detached3 \
276"