summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/unfs3/unfs3_0.9.22.r497.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/unfs3/unfs3_0.9.22.r497.bb')
-rw-r--r--meta/recipes-devtools/unfs3/unfs3_0.9.22.r497.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/unfs3/unfs3_0.9.22.r497.bb b/meta/recipes-devtools/unfs3/unfs3_0.9.22.r497.bb
new file mode 100644
index 0000000000..7e9d659671
--- /dev/null
+++ b/meta/recipes-devtools/unfs3/unfs3_0.9.22.r497.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Userspace NFS server v3 protocol"
2SECTION = "console/network"
3LICENSE = "unfs3"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=9475885294e17c0cc0067820d042792e"
5
6# SVN support for upstream version check isn't implemented yet
7RECIPE_UPSTREAM_VERSION = "0.9.22.r497"
8RECIPE_UPSTREAM_DATE = "Oct 08, 2015"
9CHECK_DATE = "Dec 10, 2015"
10
11DEPENDS = "flex-native bison-native flex"
12DEPENDS_append_class-nativesdk += "flex-nativesdk"
13
14SRC_URI[md5sum] = "3687acc4ee992e536472365dd99712a7"
15SRC_URI[sha256sum] = "274b43ada9c6eea1da26eb7010d72889c5278984ba0b50dff4e093057d4d64f8"
16
17MOD_PV = "497"
18S = "${WORKDIR}/trunk"
19SRC_URI = "svn://svn.code.sf.net/p/unfs3/code;module=trunk;rev=${MOD_PV};protocol=http \
20 file://unfs3_parallel_build.patch \
21 file://alternate_rpc_ports.patch \
22 file://fix_pid_race_parent_writes_child_pid.patch \
23 file://fix_compile_warning.patch \
24 file://rename_fh_cache.patch \
25 file://relative_max_socket_path_len.patch \
26 file://tcp_no_delay.patch \
27 "
28BBCLASSEXTEND = "native nativesdk"
29
30inherit autotools
31EXTRA_OECONF_append_class-native = " --sbindir=${bindir}"
32
33# Turn off these header detects else the inode search
34# will walk entire file systems and this is a real problem
35# if you have 2 TB of files to walk in your file system
36CACHED_CONFIGUREVARS = "ac_cv_header_mntent_h=no ac_cv_header_sys_mnttab_h=no"