summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/unfs3/unfs3_0.9.22.r490.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/unfs3/unfs3_0.9.22.r490.bb')
-rw-r--r--meta/recipes-devtools/unfs3/unfs3_0.9.22.r490.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-devtools/unfs3/unfs3_0.9.22.r490.bb b/meta/recipes-devtools/unfs3/unfs3_0.9.22.r490.bb
new file mode 100644
index 0000000000..3d88b42733
--- /dev/null
+++ b/meta/recipes-devtools/unfs3/unfs3_0.9.22.r490.bb
@@ -0,0 +1,44 @@
1DESCRIPTION = "Userspace NFS server v3 protocol"
2SECTION = "console/network"
3LICENSE = "unfs3"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=9475885294e17c0cc0067820d042792e"
5
6RDEPENDS_${PN} = "pseudo"
7RDEPENDS_${PN}_class-native = "pseudo-native"
8RDEPENDS_${PN}_class-nativesdk = "pseudo-nativesdk"
9DEPENDS = "flex-native bison-native"
10DEPENDS_class-nativesdk += "flex-nativesdk"
11
12SRC_URI[md5sum] = "3687acc4ee992e536472365dd99712a7"
13SRC_URI[sha256sum] = "274b43ada9c6eea1da26eb7010d72889c5278984ba0b50dff4e093057d4d64f8"
14
15MOD_PV = "490"
16S = "${WORKDIR}/trunk"
17SRC_URI = "svn://svn.code.sf.net/p/unfs3/code;module=trunk;rev=${MOD_PV} \
18 file://unfs3_parallel_build.patch \
19 file://alternate_rpc_ports.patch \
20 file://fix_pid_race_parent_writes_child_pid.patch \
21 file://fix_compile_warning.patch \
22 file://rename_fh_cache.patch \
23 file://relative_max_socket_path_len.patch \
24 file://fix_warnings.patch \
25 file://tcp_no_delay.patch \
26 "
27BBCLASSEXTEND = "native nativesdk"
28
29inherit autotools
30
31# Turn off these header detects else the inode search
32# will walk entire file systems and this is a real problem
33# if you have 2 TB of files to walk in your file system
34CACHED_CONFIGUREVARS = "ac_cv_header_mntent_h=no ac_cv_header_sys_mnttab_h=no"
35
36# This recipe is intended for -native and -nativesdk builds only,
37# not target installs:
38python __anonymous () {
39 import re
40
41 pn = d.getVar("PN", True)
42 if not pn.endswith('-native') and not pn.startswith('nativesdk-'):
43 raise bb.parse.SkipPackage("unfs3 is intended for native/nativesdk builds only")
44}