summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ubootchart/ubootchart_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/ubootchart/ubootchart_svn.bb')
-rw-r--r--meta/recipes-devtools/ubootchart/ubootchart_svn.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ubootchart/ubootchart_svn.bb b/meta/recipes-devtools/ubootchart/ubootchart_svn.bb
new file mode 100644
index 0000000000..b13755e855
--- /dev/null
+++ b/meta/recipes-devtools/ubootchart/ubootchart_svn.bb
@@ -0,0 +1,39 @@
1SUMMARY = "A boot profiling tool"
2HOMEPAGE = "http://code.google.com/p/ubootchart/"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=8f0e2cd40e05189ec81232da84bd6e1a"
5SRCREV = "12"
6PV = "0.0+r${SRCPV}"
7PR = "r6"
8
9#RRECOMMENDS_${PN} = "acct"
10
11SRC_URI = "svn://ubootchart.googlecode.com/svn/;protocol=http;module=trunk \
12 file://sysvinit.patch;striplevel=0 \
13 file://ubootchart-stop \
14 file://ubootchart.desktop"
15
16S = "${WORKDIR}/trunk"
17
18inherit update-alternatives
19
20ALTERNATIVE_${PN} = "init"
21ALTERNATIVE_TARGET[init] = "${base_sbindir}/ubootchartd"
22ALTERNATIVE_LINK_NAME[init] = "${base_sbindir}/init"
23ALTERNATIVE_PRIORITY = "70"
24
25do_compile() {
26 ${CC} ${CFLAGS} ${LDFLAGS} ${LIBS} ${INCLUDES} ${S}/ubootchartd_bin.c -o ubootchartd_bin
27}
28
29do_install() {
30 install -m 0755 -d ${D}${base_sbindir} ${D}${sysconfdir}/ubootchart ${D}${datadir}/applications
31 install -m 0755 ${S}/ubootchartd_bin ${D}${base_sbindir}
32 install -m 0755 ${S}/ubootchartd ${D}${base_sbindir}
33 install -m 0644 ${S}/ubootchart.conf ${D}${sysconfdir}/ubootchart
34 install -m 0755 ${S}/start.sh ${D}${sysconfdir}/ubootchart
35 install -m 0755 ${S}/finish.sh ${D}${sysconfdir}/ubootchart
36
37 install -m 0755 ${WORKDIR}/ubootchart-stop ${D}${base_sbindir}
38 install -m 0644 ${WORKDIR}/ubootchart.desktop ${D}${datadir}/applications
39}