summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcltk/tcl_8.6.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/tcltk/tcl_8.6.6.bb')
-rw-r--r--meta/recipes-devtools/tcltk/tcl_8.6.6.bb97
1 files changed, 97 insertions, 0 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.6.bb b/meta/recipes-devtools/tcltk/tcl_8.6.6.bb
new file mode 100644
index 0000000000..2dd0a7ae98
--- /dev/null
+++ b/meta/recipes-devtools/tcltk/tcl_8.6.6.bb
@@ -0,0 +1,97 @@
1SUMMARY = "Tool Command Language"
2HOMEPAGE = "http://tcl.sourceforge.net"
3SECTION = "devel/tcltk"
4
5# http://www.tcl.tk/software/tcltk/license.html
6LICENSE = "tcl & BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://../license.terms;md5=058f6229798281bbcac4239c788cfa38 \
8 file://../compat/license.terms;md5=058f6229798281bbcac4239c788cfa38 \
9 file://../library/license.terms;md5=058f6229798281bbcac4239c788cfa38 \
10 file://../macosx/license.terms;md5=058f6229798281bbcac4239c788cfa38 \
11 file://../tests/license.terms;md5=058f6229798281bbcac4239c788cfa38 \
12 file://../win/license.terms;md5=058f6229798281bbcac4239c788cfa38 \
13"
14
15DEPENDS = "tcl-native zlib"
16
17BASE_SRC_URI = "${SOURCEFORGE_MIRROR}/tcl/${BPN}${PV}-src.tar.gz \
18 file://tcl-add-soname.patch"
19SRC_URI = "${BASE_SRC_URI} \
20 file://fix_non_native_build_issue.patch \
21 file://fix_issue_with_old_distro_glibc.patch \
22 file://no_packages.patch \
23 file://tcl-remove-hardcoded-install-path.patch \
24 file://alter-includedir.patch \
25 file://run-ptest \
26"
27SRC_URI[md5sum] = "5193aea8107839a79df8ac709552ecb7"
28SRC_URI[sha256sum] = "a265409781e4b3edcc4ef822533071b34c3dc6790b893963809b9fe221befe07"
29
30SRC_URI_class-native = "${BASE_SRC_URI}"
31
32S = "${WORKDIR}/${BPN}${PV}/unix"
33
34VER = "${PV}"
35
36inherit autotools ptest binconfig
37
38DEPENDS_class-native = "zlib-native"
39
40EXTRA_OECONF = "--enable-threads --disable-rpath --libdir=${libdir}"
41
42do_configure() {
43 cd ${S}
44 gnu-configize
45 cd ${B}
46 oe_runconf
47}
48
49do_compile_prepend() {
50 echo > ${S}/../compat/fixstrtod.c
51}
52
53do_install() {
54 autotools_do_install install-private-headers
55 ln -sf ./tclsh${VER} ${D}${bindir}/tclsh
56 ln -sf tclsh8.6 ${D}${bindir}/tclsh${VER}
57 sed -i "s+-L${B}+-L${STAGING_LIBDIR}+g" tclConfig.sh
58 sed -i "s+${WORKDIR}+${STAGING_INCDIR}+g" tclConfig.sh
59 install -d ${D}${bindir_crossscripts}
60 install -m 0755 tclConfig.sh ${D}${bindir_crossscripts}
61 install -m 0755 tclConfig.sh ${D}${libdir}
62 cd ..
63 for dir in compat generic unix; do
64 install -d ${D}${includedir}/${BPN}${VER}/$dir
65 install -m 0644 ${S}/../$dir/*.h ${D}${includedir}/${BPN}${VER}/$dir/
66 done
67}
68
69SYSROOT_DIRS += "${bindir_crossscripts}"
70
71PACKAGES =+ "tcl-lib"
72FILES_tcl-lib = "${libdir}/libtcl8.6.so.*"
73FILES_${PN} += "${libdir}/tcl${VER} ${libdir}/tcl8.6 ${libdir}/tcl8"
74FILES_${PN}-dev += "${libdir}/tclConfig.sh ${libdir}/tclooConfig.sh"
75
76# isn't getting picked up by shlibs code
77RDEPENDS_${PN} += "tcl-lib"
78RDEPENDS_${PN}_class-native = ""
79RDEPENDS_${PN}-ptest += "libgcc"
80
81BBCLASSEXTEND = "native"
82
83do_compile_ptest() {
84 oe_runmake tcltest
85}
86
87do_install_ptest() {
88 cp ${B}/tcltest ${D}${PTEST_PATH}
89 cp -r ${S}/../library ${D}${PTEST_PATH}
90 cp -r ${S}/../tests ${D}${PTEST_PATH}
91}
92
93# Fix some paths that might be used by Tcl extensions
94BINCONFIG_GLOB = "*Config.sh"
95
96# Fix the path in sstate
97SSTATE_SCAN_FILES += "*Config.sh"