summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/tcf-agent/tcf-agent_git.bb')
-rw-r--r--meta/recipes-devtools/tcf-agent/tcf-agent_git.bb20
1 files changed, 10 insertions, 10 deletions
diff --git a/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb b/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
index 87369c47dd..48e6e02f05 100644
--- a/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
+++ b/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
@@ -19,13 +19,13 @@ SRC_URI = "git://git.eclipse.org/gitroot/tcf/org.eclipse.tcf.agent \
19 " 19 "
20 20
21DEPENDS = "util-linux openssl" 21DEPENDS = "util-linux openssl"
22RDEPENDS_${PN} = "bash" 22RDEPENDS:${PN} = "bash"
23 23
24S = "${WORKDIR}/git/agent" 24S = "${WORKDIR}/git/agent"
25 25
26inherit update-rc.d systemd 26inherit update-rc.d systemd
27 27
28SYSTEMD_SERVICE_${PN} = "tcf-agent.service" 28SYSTEMD_SERVICE:${PN} = "tcf-agent.service"
29 29
30INITSCRIPT_NAME = "tcf-agent" 30INITSCRIPT_NAME = "tcf-agent"
31INITSCRIPT_PARAMS = "start 99 3 5 . stop 20 0 1 2 6 ." 31INITSCRIPT_PARAMS = "start 99 3 5 . stop 20 0 1 2 6 ."
@@ -43,14 +43,14 @@ LCL_STOP_SERVICES = "-DSERVICE_RunControl=0 -DSERVICE_Breakpoints=0 \
43 43
44# These features don't compile for several cases. 44# These features don't compile for several cases.
45# 45#
46CFLAGS_append_arc = " ${LCL_STOP_SERVICES}" 46CFLAGS:append:arc = " ${LCL_STOP_SERVICES}"
47CFLAGS_append_mips = " ${LCL_STOP_SERVICES}" 47CFLAGS:append:mips = " ${LCL_STOP_SERVICES}"
48CFLAGS_append_mips64 = " ${LCL_STOP_SERVICES}" 48CFLAGS:append:mips64 = " ${LCL_STOP_SERVICES}"
49CFLAGS_append_libc-musl = " ${LCL_STOP_SERVICES}" 49CFLAGS:append:libc-musl = " ${LCL_STOP_SERVICES}"
50CFLAGS_append_powerpc64 = " ${LCL_STOP_SERVICES}" 50CFLAGS:append:powerpc64 = " ${LCL_STOP_SERVICES}"
51CFLAGS_append_powerpc64le = " ${LCL_STOP_SERVICES}" 51CFLAGS:append:powerpc64le = " ${LCL_STOP_SERVICES}"
52CFLAGS_append_riscv64 = " ${LCL_STOP_SERVICES}" 52CFLAGS:append:riscv64 = " ${LCL_STOP_SERVICES}"
53CFLAGS_append_riscv32 = " ${LCL_STOP_SERVICES}" 53CFLAGS:append:riscv32 = " ${LCL_STOP_SERVICES}"
54 54
55do_install() { 55do_install() {
56 oe_runmake install INSTALLROOT=${D} 56 oe_runmake install INSTALLROOT=${D}