summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/swig/swig_4.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/swig/swig_4.2.1.bb')
-rw-r--r--meta/recipes-devtools/swig/swig_4.2.1.bb45
1 files changed, 9 insertions, 36 deletions
diff --git a/meta/recipes-devtools/swig/swig_4.2.1.bb b/meta/recipes-devtools/swig/swig_4.2.1.bb
index 7062d4e9aa..b564be9b36 100644
--- a/meta/recipes-devtools/swig/swig_4.2.1.bb
+++ b/meta/recipes-devtools/swig/swig_4.2.1.bb
@@ -13,51 +13,16 @@ SECTION = "devel"
13DEPENDS = "libpcre2 bison-native" 13DEPENDS = "libpcre2 bison-native"
14 14
15SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz \ 15SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz \
16 file://0001-Use-proc-self-exe-for-swig-swiglib-on-non-Win32-plat.patch \
17 file://0001-configure-use-pkg-config-for-pcre-detection.patch \
18 file://determinism.patch \ 16 file://determinism.patch \
19 " 17 "
20SRC_URI[sha256sum] = "fa045354e2d048b2cddc69579e4256245d4676894858fcf0bab2290ecf59b7d8" 18SRC_URI[sha256sum] = "fa045354e2d048b2cddc69579e4256245d4676894858fcf0bab2290ecf59b7d8"
21UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/swig/files/swig/" 19UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/swig/files/swig/"
22UPSTREAM_CHECK_REGEX = "swig-(?P<pver>\d+(\.\d+)+)" 20UPSTREAM_CHECK_REGEX = "swig-(?P<pver>\d+(\.\d+)+)"
23 21
24inherit autotools python3native pkgconfig 22inherit cmake pkgconfig
25
26EXTRA_OECONF = " \
27 --with-python3=${PYTHON} \
28 --without-allegrocl \
29 --without-android \
30 --without-boost \
31 --without-chicken \
32 --without-clisp \
33 --without-csharp \
34 --without-d \
35 --without-gcj \
36 --without-go \
37 --without-guile \
38 --without-java \
39 --without-lua \
40 --without-mzscheme \
41 --without-ocaml \
42 --without-octave \
43 --without-perl5 \
44 --without-pike \
45 --without-php \
46 --without-r \
47 --without-ruby \
48 --without-tcl \
49"
50
51EXTRA_AUTORECONF += "-I Tools/config"
52 23
53BBCLASSEXTEND = "native nativesdk" 24BBCLASSEXTEND = "native nativesdk"
54 25
55# necessary together with bison dependency until a new upstream version after
56# 3.0.12 includes 0001-Fix-generated-code-for-constant-expressions-containi.patch
57do_configure:append() {
58 mkdir -p ${B}/Source/CParse
59}
60
61do_install:append:class-nativesdk() { 26do_install:append:class-nativesdk() {
62 cd ${D}${bindir} 27 cd ${D}${bindir}
63 ln -s swig swig2.0 28 ln -s swig swig2.0
@@ -70,3 +35,11 @@ def swiglib_relpath(d):
70do_install:append:class-native() { 35do_install:append:class-native() {
71 create_wrapper ${D}${bindir}/swig SWIG_LIB='`dirname $''realpath`'/${@swiglib_relpath(d)} 36 create_wrapper ${D}${bindir}/swig SWIG_LIB='`dirname $''realpath`'/${@swiglib_relpath(d)}
72} 37}
38
39PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess"
40src_package_preprocess () {
41 # Trim build paths from comments and defines in generated sources to ensure reproducibility
42 sed -i -e "s,${WORKDIR},,g" \
43 -e "s,YY_YY_.*_CPARSE_PARSER_H_INCLUDED,YY_YY_CPARSE_PARSER_H_INCLUDED,g" \
44 ${B}/Source/CParse/parser.*
45}