summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/swig/swig_4.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/swig/swig_4.2.1.bb')
-rw-r--r--meta/recipes-devtools/swig/swig_4.2.1.bb69
1 files changed, 67 insertions, 2 deletions
diff --git a/meta/recipes-devtools/swig/swig_4.2.1.bb b/meta/recipes-devtools/swig/swig_4.2.1.bb
index 4b438a7298..7062d4e9aa 100644
--- a/meta/recipes-devtools/swig/swig_4.2.1.bb
+++ b/meta/recipes-devtools/swig/swig_4.2.1.bb
@@ -1,7 +1,72 @@
1require ${BPN}.inc 1SUMMARY = "SWIG - Simplified Wrapper and Interface Generator"
2DESCRIPTION = "SWIG is a compiler that makes it easy to integrate C and C++ \
3code with other languages including Perl, Tcl, Ruby, Python, Java, Guile, \
4Mzscheme, Chicken, OCaml, Pike, and C#."
5HOMEPAGE = "http://swig.sourceforge.net/"
6LICENSE = "BSD-3-Clause & GPL-3.0-only"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e7807a6282784a7dde4c846626b08fc6 \
8 file://LICENSE-GPL;md5=d32239bcb673463ab874e80d47fae504 \
9 file://LICENSE-UNIVERSITIES;md5=8ce9dcc8f7c994de4a408b205c72ba08"
2 10
3SRC_URI += "file://0001-Use-proc-self-exe-for-swig-swiglib-on-non-Win32-plat.patch \ 11SECTION = "devel"
12
13DEPENDS = "libpcre2 bison-native"
14
15SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz \
16 file://0001-Use-proc-self-exe-for-swig-swiglib-on-non-Win32-plat.patch \
4 file://0001-configure-use-pkg-config-for-pcre-detection.patch \ 17 file://0001-configure-use-pkg-config-for-pcre-detection.patch \
5 file://determinism.patch \ 18 file://determinism.patch \
6 " 19 "
7SRC_URI[sha256sum] = "fa045354e2d048b2cddc69579e4256245d4676894858fcf0bab2290ecf59b7d8" 20SRC_URI[sha256sum] = "fa045354e2d048b2cddc69579e4256245d4676894858fcf0bab2290ecf59b7d8"
21UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/swig/files/swig/"
22UPSTREAM_CHECK_REGEX = "swig-(?P<pver>\d+(\.\d+)+)"
23
24inherit autotools python3native pkgconfig
25
26EXTRA_OECONF = " \
27 --with-python3=${PYTHON} \
28 --without-allegrocl \
29 --without-android \
30 --without-boost \
31 --without-chicken \
32 --without-clisp \
33 --without-csharp \
34 --without-d \
35 --without-gcj \
36 --without-go \
37 --without-guile \
38 --without-java \
39 --without-lua \
40 --without-mzscheme \
41 --without-ocaml \
42 --without-octave \
43 --without-perl5 \
44 --without-pike \
45 --without-php \
46 --without-r \
47 --without-ruby \
48 --without-tcl \
49"
50
51EXTRA_AUTORECONF += "-I Tools/config"
52
53BBCLASSEXTEND = "native nativesdk"
54
55# necessary together with bison dependency until a new upstream version after
56# 3.0.12 includes 0001-Fix-generated-code-for-constant-expressions-containi.patch
57do_configure:append() {
58 mkdir -p ${B}/Source/CParse
59}
60
61do_install:append:class-nativesdk() {
62 cd ${D}${bindir}
63 ln -s swig swig2.0
64}
65
66def swiglib_relpath(d):
67 swiglib = d.getVar('datadir') + "/" + d.getVar('BPN') + "/" + d.getVar('PV')
68 return os.path.relpath(swiglib, d.getVar('bindir'))
69
70do_install:append:class-native() {
71 create_wrapper ${D}${bindir}/swig SWIG_LIB='`dirname $''realpath`'/${@swiglib_relpath(d)}
72}