summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/subversion/subversion_1.8.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/subversion/subversion_1.8.10.bb')
-rw-r--r--meta/recipes-devtools/subversion/subversion_1.8.10.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-devtools/subversion/subversion_1.8.10.bb b/meta/recipes-devtools/subversion/subversion_1.8.10.bb
new file mode 100644
index 0000000000..b223d26b3d
--- /dev/null
+++ b/meta/recipes-devtools/subversion/subversion_1.8.10.bb
@@ -0,0 +1,49 @@
1SUMMARY = "Subversion (svn) version control system client"
2SECTION = "console/network"
3DEPENDS = "apr-util serf sqlite3 file"
4RDEPENDS_${PN} = "serf"
5LICENSE = "Apache-2"
6HOMEPAGE = "http://subversion.tigris.org"
7
8BBCLASSEXTEND = "native"
9
10inherit gettext
11
12SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
13 file://libtool2.patch \
14 file://disable_macos.patch \
15"
16SRC_URI[md5sum] = "3068256761b40863df96128834d6b71b"
17SRC_URI[sha256sum] = "1cc900c8a7974337c3ed389dc6b5c59012ec48c7d4107ae31fd7c929ded47dcc"
18
19LIC_FILES_CHKSUM = "file://LICENSE;md5=1c2f0119e478700b5428e26386cff923"
20
21PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl"
22PACKAGECONFIG[gnome-keyring] = "--with-gnome-keyring,--without-gnome-keyring,glib-2.0 gnome-keyring"
23
24EXTRA_OECONF = " \
25 --without-berkeley-db --without-apxs \
26 --without-swig --with-apr=${STAGING_BINDIR_CROSS} \
27 --with-apr-util=${STAGING_BINDIR_CROSS} \
28 --disable-keychain \
29 ac_cv_path_RUBY=none"
30
31inherit autotools
32
33export LDFLAGS += " -L${STAGING_LIBDIR} "
34
35acpaths = "-I build/ -I build/ac-macros/"
36
37do_configure_prepend () {
38 rm -f ${S}/libtool
39 rm -f ${S}/build/libtool.m4 ${S}/build/ltmain.sh ${S}/build/ltoptions.m4 ${S}/build/ltsugar.m4 ${S}/build/ltversion.m4 ${S}/build/lt~obsolete.m4
40 rm -f ${S}/aclocal.m4
41 sed -i -e 's:with_sasl="/usr/local":with_sasl="${STAGING_DIR}":' ${S}/build/ac-macros/sasl.m4
42}
43
44#| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_local/libsvn_ra_local-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_repos/libsvn_repos-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| /usr/bin/ld: cannot find -lsvn_delta-1| collect2: ld returned 1 exit status| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_svn/libsvn_ra_svn-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_serf/libsvn_ra_serf-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'
45#| x86_64-linux-libtool: install: error: relink `libsvn_ra_serf-1.la' with the above command before installing it
46#| x86_64-linux-libtool: install: warning: `../../subversion/libsvn_repos/libsvn_repos-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'
47#| /home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/subversion-1.8.9/build-outputs.mk:1090: recipe for target 'install-serf-lib' failed
48#| make: *** [install-serf-lib] Error 1
49PARALLEL_MAKEINST = ""