summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_4.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.8.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_4.8.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.8.bb b/meta/recipes-devtools/strace/strace_4.8.bb
new file mode 100644
index 0000000000..24827458cc
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace_4.8.bb
@@ -0,0 +1,46 @@
1SUMMARY = "System call tracing tool"
2HOMEPAGE = "http://strace.sourceforge.net"
3SECTION = "console/utils"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=124500c21e856f0912df29295ba104c7"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
8 file://git-version-gen \
9 file://strace-add-configure-options.patch \
10 file://Makefile-ptest.patch \
11 file://run-ptest \
12 "
13
14SRC_URI[md5sum] = "c575ef43829586801f514fd91bfe7575"
15SRC_URI[sha256sum] = "f492291f07a7c805c07a8395cce1ea054a6401ad414f4cc12185672215e1d7f8"
16
17inherit autotools ptest
18RDEPENDS_${PN}-ptest += "make"
19
20PACKAGECONFIG_class-target ?= "libaio ${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
21
22PACKAGECONFIG[libaio] = "--enable-aio,--disable-aio,libaio"
23PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl"
24
25export INCLUDES = "-I. -I./linux"
26
27TESTDIR = "tests"
28
29do_configure_prepend() {
30 cp ${WORKDIR}/git-version-gen ${S}
31}
32
33do_install_append() {
34 # We don't ship strace-graph here because it needs perl
35 rm ${D}${bindir}/strace-graph
36}
37
38do_compile_ptest() {
39 oe_runmake -C ${TESTDIR} buildtest-TESTS
40}
41
42do_install_ptest() {
43 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
44}
45
46BBCLASSEXTEND = "native"